Debian LTS: DLA-3229-1: node-log4js security update | LinuxSecurity...

- -----------------------------------------------------------------------
Debian LTS Advisory DLA-3229-1              [email protected]
https://www.debian.org/lts/security/                      Utkarsh Gupta
December 07, 2022                           https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package        : node-log4js
Version        : 4.0.2-2+deb10u1
CVE ID         : CVE-2022-21704

In node-log4js, a port of log4js in Node.js, default file permissions
for log files created by the file, fileSync, and dateFile appenders are
world-readable. This could cause problems if log files contain sensitive
information. This would affect any users that have not supplied their
own permissions for the files via the mode parameter in the config.

For Debian 10 buster, this problem has been fixed in version
4.0.2-2+deb10u1.

We recommend that you upgrade your node-log4js packages.

For the detailed security status of node-log4js please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/node-log4js

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3229-1: node-log4js security update

December 7, 2022
In node-log4js, a port of log4js in Node.js, default file permissions for log files created by the file, fileSync, and dateFile appenders are world-readable

Summary

For Debian 10 buster, this problem has been fixed in version
4.0.2-2+deb10u1.

We recommend that you upgrade your node-log4js packages.

For the detailed security status of node-log4js please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/node-log4js

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : node-log4js
Version : 4.0.2-2+deb10u1
CVE ID : CVE-2022-21704