Debian LTS: DLA-3257-1: emacs security update | LinuxSecurity.com

- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3257-1                [email protected]
https://www.debian.org/lts/security/                           Chris Lamb
December 31, 2022                             https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : emacs
Version        : 1:26.1+1-3.2+deb10u3
CVE ID         : CVE-2022-45939
Debian Bug     : 1025009

It was discovered that there was an issue in Emacs where where
attackers could have executed arbitrary commands via shell
metacharacters in the name of a source-code file.

This was because lib-src/etags.c used the system(3) library function
when calling the (external) ctags(1) binary.

For Debian 10 buster, this problem has been fixed in version
1:26.1+1-3.2+deb10u3.

We recommend that you upgrade your emacs packages.

For the detailed security status of emacs please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/emacs

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3257-1: emacs security update

December 31, 2022
It was discovered that there was an issue in Emacs where where attackers could have executed arbitrary commands via shell metacharacters in the name of a source-code file

Summary

This was because lib-src/etags.c used the system(3) library function
when calling the (external) ctags(1) binary.

For Debian 10 buster, this problem has been fixed in version
1:26.1+1-3.2+deb10u3.

We recommend that you upgrade your emacs packages.

For the detailed security status of emacs please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/emacs

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : emacs
Version : 1:26.1+1-3.2+deb10u3
CVE ID : CVE-2022-45939
Debian Bug : 1025009

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.