Debian LTS: DLA-3264-1: ruby-sinatra security update | LinuxSecurit...

- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3264-1                [email protected]
https://www.debian.org/lts/security/                           Chris Lamb
January 10, 2023                              https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : ruby-sinatra
Version        : 2.0.5-4+deb10u2
CVE ID         : CVE-2022-45442
Debian Bug     : 1025125

It was discovered that there was a potential reflected file download
(RFD) vulnerability in ruby-sinatra, a Ruby library for writing HTTP
applications. A Content-Disposition HTTP header was being incorrectly
derived from a potentially user-supplied filename.

For Debian 10 buster, this problem has been fixed in version
2.0.5-4+deb10u2.

We recommend that you upgrade your ruby-sinatra packages.

For the detailed security status of ruby-sinatra please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/ruby-sinatra

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3264-1: ruby-sinatra security update

January 10, 2023
It was discovered that there was a potential reflected file download (RFD) vulnerability in ruby-sinatra, a Ruby library for writing HTTP applications

Summary

For Debian 10 buster, this problem has been fixed in version
2.0.5-4+deb10u2.

We recommend that you upgrade your ruby-sinatra packages.

For the detailed security status of ruby-sinatra please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/ruby-sinatra

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : ruby-sinatra
Version : 2.0.5-4+deb10u2
CVE ID : CVE-2022-45442
Debian Bug : 1025125

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.