Discover Government News


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3771-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                          Adrian Bunk
March 24, 2024                                https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : python2.7
Version        : 2.7.16-2+deb10u4
CVE ID         : CVE-2024-0450

The zipfile module was vulnerable to “quoted-overlap” zip-bombs
in the Python 2 interpreter.

For Debian 10 buster, this problem has been fixed in version
2.7.16-2+deb10u4.

We recommend that you upgrade your python2.7 packages.

For the detailed security status of python2.7 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/python2.7

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3771-1: python2.7 security update

March 24, 2024
The zipfile module was vulnerable to “quoted-overlap” zip-bombs in the Python 2 interpreter

Summary

For Debian 10 buster, this problem has been fixed in version
2.7.16-2+deb10u4.

We recommend that you upgrade your python2.7 packages.

For the detailed security status of python2.7 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/python2.7

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : python2.7
Version : 2.7.16-2+deb10u4
CVE ID : CVE-2024-0450

Related News