- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3832-1                debian-lts@lists.debian.org
https://www.debian.org/lts/security/                   Bastien Roucariès
June 17, 2024                                 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : pymongo
Version        : 3.7.1-1.1+deb10u1
CVE ID         : CVE-2024-5629

An out-of-bounds read in the 'bson' module allowed deserialization of
malformed BSON provided by a Server to raise an exception which may contain
arbitrary application memory.

For Debian 10 buster, this problem has been fixed in version
3.7.1-1.1+deb10u1.

We recommend that you upgrade your pymongo packages.

For the detailed security status of pymongo please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/pymongo

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3832-1: pymongo Security Advisory Updates

June 17, 2024
An out-of-bounds read in the 'bson' module allowed deserialization of malformed BSON provided by a Server to raise an exception which may contain arbitrary application memory

Summary

For Debian 10 buster, this problem has been fixed in version
3.7.1-1.1+deb10u1.

We recommend that you upgrade your pymongo packages.

For the detailed security status of pymongo please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/pymongo

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : pymongo
Version : 3.7.1-1.1+deb10u1
CVE ID : CVE-2024-5629

Related News