Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201701-42
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: file: Multiple vulnerabilities
     Date: January 17, 2017
     Bugs: #526544, #538660, #539106, #579306
       ID: 201701-42

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities have been found in file, the worst of which
could allow remote attackers to execute arbitrary code.

Background
=========
file is a utility that guesses a file format by scanning binary data
for patterns.

Affected packages
================
    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  sys-apps/file                 < 5.23                     >= 5.23 

Description
==========
Multiple vulnerabilities have been discovered in file. Please review
the CVE identifiers referenced below for details.

Impact
=====
A remote attacker could entice a user or automated system to process a
specially crafted input file, possibly resulting in execution of
arbitrary code with the privileges of the process, a Denial of Service
condition or have other unspecified impacts.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All file users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-apps/file-5.23"

References
=========
[ 1 ] CVE-2014-3710
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3710
[ 2 ] CVE-2014-9652
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9652
[ 3 ] CVE-2014-9653
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9653
[ 4 ] CVE-2015-8865
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-8865

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201701-42

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
======
Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/


Gentoo: GLSA-201701-42: file: Multiple vulnerabilities

Multiple vulnerabilities have been found in file, the worst of which could allow remote attackers to execute arbitrary code.

Summary

Multiple vulnerabilities have been discovered in file. Please review the CVE identifiers referenced below for details.

Resolution

All file users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=sys-apps/file-5.23"

References

[ 1 ] CVE-2014-3710 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3710 [ 2 ] CVE-2014-9652 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9652 [ 3 ] CVE-2014-9653 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9653 [ 4 ] CVE-2015-8865 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-8865

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website: https://security.gentoo.org/glsa/201701-42

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: file: Multiple vulnerabilities
Date: January 17, 2017
Bugs: #526544, #538660, #539106, #579306
ID: 201701-42

Synopsis

Multiple vulnerabilities have been found in file, the worst of which could allow remote attackers to execute arbitrary code.

Background

file is a utility that guesses a file format by scanning binary data for patterns.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 sys-apps/file < 5.23 >= 5.23

Impact

===== A remote attacker could entice a user or automated system to process a specially crafted input file, possibly resulting in execution of arbitrary code with the privileges of the process, a Denial of Service condition or have other unspecified impacts.

Workaround

There is no known workaround at this time.

Related News