- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202004-13
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Low
    Title: Git: Information disclosure
     Date: April 23, 2020
     Bugs: #717156, #718710
       ID: 202004-13

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities have been found in Git which might all allow
attackers to access sensitive information.

Background
=========
Git is a free and open source distributed version control system
designed to handle everything from small to very large projects with
speed and efficiency.

Affected packages
================
    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-vcs/git                  < 2.26.2                 *>= 2.23.3
                                                           *>= 2.24.3
                                                           *>= 2.25.4
                                                           *>= 2.26.2

Description
==========
Multiple vulnerabilities have been discovered in Git. Please review the
CVE identifiers referenced below for details.

Impact
=====
A remote attacker, by providing a specially crafted URL, could possibly
trick Git into returning credential information for a wrong host.

Workaround
=========
Disabling credential helpers will prevent this vulnerability.

Resolution
=========
All Git 2.23.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.23.3"

All Git 2.24.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.24.3"

All Git 2.25.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.25.4"

All Git 2.26.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.26.2"

References
=========
[ 1 ] CVE-2020-11008
      https://nvd.nist.gov/vuln/detail/CVE-2020-11008
[ 2 ] CVE-2020-5260
      https://nvd.nist.gov/vuln/detail/CVE-2020-5260

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202004-13

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
======
Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202004-13: Git: Information disclosure

Multiple vulnerabilities have been found in Git which might all allow attackers to access sensitive information.

Summary

Multiple vulnerabilities have been discovered in Git. Please review the CVE identifiers referenced below for details.

Resolution

All Git 2.23.x users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.23.3"
All Git 2.24.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.24.3"
All Git 2.25.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.25.4"
All Git 2.26.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-vcs/git-2.26.2"

References

[ 1 ] CVE-2020-11008 https://nvd.nist.gov/vuln/detail/CVE-2020-11008 [ 2 ] CVE-2020-5260 https://nvd.nist.gov/vuln/detail/CVE-2020-5260

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website: https://security.gentoo.org/glsa/202004-13

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: Git: Information disclosure
Date: April 23, 2020
Bugs: #717156, #718710
ID: 202004-13

Synopsis

Multiple vulnerabilities have been found in Git which might all allow attackers to access sensitive information.

Background

Git is a free and open source distributed version control system designed to handle everything from small to very large projects with speed and efficiency.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-vcs/git < 2.26.2 *>= 2.23.3 *>= 2.24.3 *>= 2.25.4 *>= 2.26.2

Impact

===== A remote attacker, by providing a specially crafted URL, could possibly trick Git into returning credential information for a wrong host.

Workaround

Disabling credential helpers will prevent this vulnerability.