Gentoo: GLSA-202005-10: libmicrodns: Multiple vulnerabilities

    Date 14 May 2020
    121
    Posted By LinuxSecurity Advisories
    Multiple vulnerabilities have been found in libmicrodns, the worst of which could result in the arbitrary execution of code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 202005-10
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                               https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: libmicrodns: Multiple vulnerabilities
         Date: May 14, 2020
         Bugs: #714606
           ID: 202005-10
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in libmicrodns, the worst of
    which could result in the arbitrary execution of code.
    
    Background
    ==========
    
    libmicrodns is an mDNS library, focused on being simple and
    cross-platform.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  net-libs/libmicrodns         < 0.1.2                    >= 0.1.2
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in libmicrodns. Please
    review the CVE identifiers and the upstream advisory referenced below
    for details.
    
    Impact
    ======
    
    Please review the referenced CVE identifiers for details.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All libmicrodns users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/libmicrodns-0.1.2"
    
    References
    ==========
    
    [ 1 ] CVE-2020-6071
          https://nvd.nist.gov/vuln/detail/CVE-2020-6071
    [ 2 ] CVE-2020-6072
          https://nvd.nist.gov/vuln/detail/CVE-2020-6072
    [ 3 ] CVE-2020-6073
          https://nvd.nist.gov/vuln/detail/CVE-2020-6073
    [ 4 ] CVE-2020-6077
          https://nvd.nist.gov/vuln/detail/CVE-2020-6077
    [ 5 ] CVE-2020-6078
          https://nvd.nist.gov/vuln/detail/CVE-2020-6078
    [ 6 ] CVE-2020-6079
          https://nvd.nist.gov/vuln/detail/CVE-2020-6079
    [ 7 ] CVE-2020-6080
          https://nvd.nist.gov/vuln/detail/CVE-2020-6080
    [ 8 ] VideoLAN-SB-VLC-309
          https://www.videolan.org/security/sb-vlc309.html
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/202005-10
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2020 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    

    LinuxSecurity Poll

    How do you feel about the elimination of the terms 'blacklist' and 'slave' from the Linux kernel?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/32-how-do-you-feel-about-the-elimination-of-the-terms-blacklist-and-slave-from-the-linux-kernel?task=poll.vote&format=json
    32
    radio
    [{"id":"112","title":"I strongly support this change - racially charged language should not be used in the code and documentation of the kernel and other open-source projects.","votes":"3","type":"x","order":"1","pct":42.86,"resources":[]},{"id":"113","title":"I'm indifferent - this small change will not affect broader issues of racial insensitivity and white privilege.","votes":"2","type":"x","order":"2","pct":28.57,"resources":[]},{"id":"114","title":"I'm opposed to this change - there is no need to change language that has been used for years. It doesn't make sense for people to take offense to terminology used in community projects.","votes":"2","type":"x","order":"3","pct":28.57,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.