Gentoo: GLSA-202107-20: Redis: Multiple vulnerabilities | LinuxSecu...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202107-20
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Redis: Multiple vulnerabilities
     Date: July 09, 2021
     Bugs: #788211
       ID: 202107-20

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Redis, the worst of which
could result in the arbitrary execution of code.

Background
==========

Redis is an open source (BSD licensed), in-memory data structure store,
used as a database, cache and message broker.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-db/redis                 < 6.0.13                  >= 6.0.13
                                                             >= 6.2.3

Description
===========

Multiple vulnerabilities have been discovered in Redis. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Redis 6.0.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/redis-6.0.13"

All Redis 6.2.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/redis-6.2.3"

References
==========

[ 1 ] CVE-2021-29477
      https://nvd.nist.gov/vuln/detail/CVE-2021-29477
[ 2 ] CVE-2021-29478
      https://nvd.nist.gov/vuln/detail/CVE-2021-29478

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202107-20

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202107-20: Redis: Multiple vulnerabilities

Summary

Multiple vulnerabilities have been discovered in Redis. Please review the CVE identifiers referenced below for details.

Resolution

All Redis 6.0.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/redis-6.0.13"
All Redis 6.2.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/redis-6.2.3"

References

[ 1 ] CVE-2021-29477 https://nvd.nist.gov/vuln/detail/CVE-2021-29477 [ 2 ] CVE-2021-29478 https://nvd.nist.gov/vuln/detail/CVE-2021-29478

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202107-20

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: Redis: Multiple vulnerabilities
Date: July 09, 2021
Bugs: #788211
ID: 202107-20

Synopsis

Multiple vulnerabilities have been found in Redis, the worst of which could result in the arbitrary execution of code.

Background

Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache and message broker.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-db/redis < 6.0.13 >= 6.0.13 >= 6.2.3

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.