- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202107-25
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Tor: Multiple vulnerabilities
     Date: July 10, 2021
     Bugs: #776586, #795969
       ID: 202107-25

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Tor, the worst of which
could result in a Denial of Service condition.

Background
==========

Tor is an implementation of second generation Onion Routing, a
connection-oriented anonymizing communication service.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-vpn/tor                 < 0.4.6.5                 >= 0.4.6.5 
                                                           >= 0.4.5.9 
                                                           >= 0.4.4.9 

Description
===========

Multiple vulnerabilities have been discovered in Tor. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Tor 0.4.6.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-vpn/tor-0.4.6.5"

All Tor 0.4.5.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-vpn/tor-0.4.5.9"

All Tor 0.4.4.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-vpn/tor-0.4.4.9"

References
==========

[ 1 ] CVE-2021-28089
      https://nvd.nist.gov/vuln/detail/CVE-2021-28089
[ 2 ] CVE-2021-28090
      https://nvd.nist.gov/vuln/detail/CVE-2021-28090
[ 3 ] CVE-2021-34548
      https://nvd.nist.gov/vuln/detail/CVE-2021-34548
[ 4 ] CVE-2021-34549
      https://nvd.nist.gov/vuln/detail/CVE-2021-34549
[ 5 ] CVE-2021-34550
      https://nvd.nist.gov/vuln/detail/CVE-2021-34550

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202107-25

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5