Gentoo: GLSA-202107-43: RPM: Multiple vulnerabilities | LinuxSecuri...

Advisories

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202107-43
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: RPM: Multiple vulnerabilities
     Date: July 20, 2021
     Bugs: #778533, #787944
       ID: 202107-43

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in RPM, the worst of which
could result in remote code execution.

Background
==========

The Red Hat Package Manager (RPM) is a command line driven package
management system capable of installing, uninstalling, verifying,
querying, and updating computer software packages.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  app-arch/rpm                < 4.16.1.3               >= 4.16.1.3 

Description
===========

Multiple vulnerabilities have been discovered in RPM. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All RPM users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=app-arch/rpm-4.16.1.3"

References
==========

[ 1 ] CVE-2021-20266
      https://nvd.nist.gov/vuln/detail/CVE-2021-20266
[ 2 ] CVE-2021-20271
      https://nvd.nist.gov/vuln/detail/CVE-2021-20271
[ 3 ] CVE-2021-3421
      https://nvd.nist.gov/vuln/detail/CVE-2021-3421

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202107-43

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202107-43: RPM: Multiple vulnerabilities

Summary

Multiple vulnerabilities have been discovered in RPM. Please review the CVE identifiers referenced below for details.

Resolution

All RPM users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=app-arch/rpm-4.16.1.3"

References

[ 1 ] CVE-2021-20266 https://nvd.nist.gov/vuln/detail/CVE-2021-20266 [ 2 ] CVE-2021-20271 https://nvd.nist.gov/vuln/detail/CVE-2021-20271 [ 3 ] CVE-2021-3421 https://nvd.nist.gov/vuln/detail/CVE-2021-3421

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202107-43

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: RPM: Multiple vulnerabilities
Date: July 20, 2021
Bugs: #778533, #787944
ID: 202107-43

Synopsis

Multiple vulnerabilities have been found in RPM, the worst of which could result in remote code execution.

Background

The Red Hat Package Manager (RPM) is a command line driven package management system capable of installing, uninstalling, verifying, querying, and updating computer software packages.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 app-arch/rpm < 4.16.1.3 >= 4.16.1.3

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.