Gentoo: GLSA-202208-05: Icinga Web 2: Multiple Vulnerabilities | Li...

Advisories

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202208-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Icinga Web 2: Multiple Vulnerabilities
     Date: August 04, 2022
     Bugs: #738024, #834802
       ID: 202208-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Icinga Web 2, the worst of
which could result in remote code execution.

Background
==========

Icinga Web 2 is a frontend for icinga2.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  www-apps/icingaweb2        < 2.9.6                      >= 2.9.6 

Description
===========

Multiple vulnerabilities have been discovered in Icinga Web 2. Please
review the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Icinga Web 2 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-apps/icingaweb2-2.9.6"

References
==========

[ 1 ] CVE-2020-24368
      https://nvd.nist.gov/vuln/detail/CVE-2020-24368
[ 2 ] CVE-2022-24714
      https://nvd.nist.gov/vuln/detail/CVE-2022-24714
[ 3 ] CVE-2022-24715
      https://nvd.nist.gov/vuln/detail/CVE-2022-24715
[ 4 ] CVE-2022-24716
      https://nvd.nist.gov/vuln/detail/CVE-2022-24716

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202208-05

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202208-05: Icinga Web 2: Multiple Vulnerabilities

Summary

Multiple vulnerabilities have been discovered in Icinga Web 2. Please review the CVE identifiers referenced below for details.

Resolution

All Icinga Web 2 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-apps/icingaweb2-2.9.6"

References

[ 1 ] CVE-2020-24368 https://nvd.nist.gov/vuln/detail/CVE-2020-24368 [ 2 ] CVE-2022-24714 https://nvd.nist.gov/vuln/detail/CVE-2022-24714 [ 3 ] CVE-2022-24715 https://nvd.nist.gov/vuln/detail/CVE-2022-24715 [ 4 ] CVE-2022-24716 https://nvd.nist.gov/vuln/detail/CVE-2022-24716

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202208-05

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: Icinga Web 2: Multiple Vulnerabilities
Date: August 04, 2022
Bugs: #738024, #834802
ID: 202208-05

Synopsis

Multiple vulnerabilities have been found in Icinga Web 2, the worst of which could result in remote code execution.

Background

Icinga Web 2 is a frontend for icinga2.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 www-apps/icingaweb2 < 2.9.6 >= 2.9.6

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.