Gentoo: GLSA-202208-28: Puma: Multiple Vulnerabilities | LinuxSecur...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202208-28
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Low
    Title: Puma: Multiple Vulnerabilities
     Date: August 14, 2022
     Bugs: #794034, #817893, #833155, #836431
       ID: 202208-28

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in Puma, the worst of
which could result in denial of service.

Background
==========

Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server
for Ruby/Rack.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  www-servers/puma           < 5.6.4                      >= 5.6.4

Description
===========

Multiple vulnerabilities have been discovered in Puma. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Puma users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=www-servers/puma-5.6.4"

References
==========

[ 1 ] CVE-2021-29509
      https://nvd.nist.gov/vuln/detail/CVE-2021-29509
[ 2 ] CVE-2021-41136
      https://nvd.nist.gov/vuln/detail/CVE-2021-41136
[ 3 ] CVE-2022-23634
      https://nvd.nist.gov/vuln/detail/CVE-2022-23634
[ 4 ] CVE-2022-24790
      https://nvd.nist.gov/vuln/detail/CVE-2022-24790

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202208-28

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202208-28: Puma: Multiple Vulnerabilities

Summary

Multiple vulnerabilities have been discovered in Puma. Please review the CVE identifiers referenced below for details.

Resolution

All Puma users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-servers/puma-5.6.4"

References

[ 1 ] CVE-2021-29509 https://nvd.nist.gov/vuln/detail/CVE-2021-29509 [ 2 ] CVE-2021-41136 https://nvd.nist.gov/vuln/detail/CVE-2021-41136 [ 3 ] CVE-2022-23634 https://nvd.nist.gov/vuln/detail/CVE-2022-23634 [ 4 ] CVE-2022-24790 https://nvd.nist.gov/vuln/detail/CVE-2022-24790

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202208-28

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: Puma: Multiple Vulnerabilities
Date: August 14, 2022
Bugs: #794034, #817893, #833155, #836431
ID: 202208-28

Synopsis

Multiple vulnerabilities have been discovered in Puma, the worst of which could result in denial of service.

Background

Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 www-servers/puma < 5.6.4 >= 5.6.4

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.