Gentoo: GLSA-202209-06: Rizin: Multiple Vulnerabilities | LinuxSecu...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202209-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Rizin: Multiple Vulnerabilities
     Date: September 25, 2022
     Bugs: #861524, #868999
       ID: 202209-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in Rizin, the worst of
which could lead to arbitrary code execution.

Background
==========

Rizin is a reverse engineering framework for binary analysis.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-util/rizin             < 0.4.1                      >= 0.4.1

Description
===========

Multiple vulnerabilities have been discovered in Rizin. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Rizin users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-util/rizin-0.4.1"

References
==========

[ 1 ] CVE-2022-34612
      https://nvd.nist.gov/vuln/detail/CVE-2022-34612
[ 2 ] CVE-2022-36039
      https://nvd.nist.gov/vuln/detail/CVE-2022-36039
[ 3 ] CVE-2022-36040
      https://nvd.nist.gov/vuln/detail/CVE-2022-36040
[ 4 ] CVE-2022-36041
      https://nvd.nist.gov/vuln/detail/CVE-2022-36041
[ 5 ] CVE-2022-36042
      https://nvd.nist.gov/vuln/detail/CVE-2022-36042
[ 6 ] CVE-2022-36043
      https://nvd.nist.gov/vuln/detail/CVE-2022-36043
[ 7 ] CVE-2022-36044
      https://nvd.nist.gov/vuln/detail/CVE-2022-36044

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202209-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202209-06: Rizin: Multiple Vulnerabilities

Summary

Multiple vulnerabilities have been discovered in Rizin. Please review the CVE identifiers referenced below for details.

Resolution

All Rizin users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-util/rizin-0.4.1"

References

[ 1 ] CVE-2022-34612 https://nvd.nist.gov/vuln/detail/CVE-2022-34612 [ 2 ] CVE-2022-36039 https://nvd.nist.gov/vuln/detail/CVE-2022-36039 [ 3 ] CVE-2022-36040 https://nvd.nist.gov/vuln/detail/CVE-2022-36040 [ 4 ] CVE-2022-36041 https://nvd.nist.gov/vuln/detail/CVE-2022-36041 [ 5 ] CVE-2022-36042 https://nvd.nist.gov/vuln/detail/CVE-2022-36042 [ 6 ] CVE-2022-36043 https://nvd.nist.gov/vuln/detail/CVE-2022-36043 [ 7 ] CVE-2022-36044 https://nvd.nist.gov/vuln/detail/CVE-2022-36044

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202209-06

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: Rizin: Multiple Vulnerabilities
Date: September 25, 2022
Bugs: #861524, #868999
ID: 202209-06

Synopsis

Multiple vulnerabilities have been discovered in Rizin, the worst of which could lead to arbitrary code execution.

Background

Rizin is a reverse engineering framework for binary analysis.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-util/rizin < 0.4.1 >= 0.4.1

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.