Gentoo: GLSA-202209-20: PHP: Multiple Vulnerabilities | LinuxSecuri...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202209-20
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: PHP: Multiple Vulnerabilities
     Date: September 29, 2022
     Bugs: #799776, #810526, #819510, #833585, #850772, #857054
       ID: 202209-20

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been discovered in PHP, the worst of which
could result in local root privilege escalation.

Background
==========

PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-lang/php               < 7.4.30:7.4             >= 7.4.30:7.4
                                < 8.0.23:8.0             >= 8.0.23:8.0
                                < 8.1.8:8.1               >= 8.1.8:8.1

Description
===========

Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PHP 7.4 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-7.4.30:7.4"

All PHP 8.0 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-8.0.23:8.0"

All PHP 8.1 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-lang/php-8.1.8:8.1"

References
==========

[ 1 ] CVE-2021-21703
      https://nvd.nist.gov/vuln/detail/CVE-2021-21703
[ 2 ] CVE-2021-21704
      https://nvd.nist.gov/vuln/detail/CVE-2021-21704
[ 3 ] CVE-2021-21705
      https://nvd.nist.gov/vuln/detail/CVE-2021-21705
[ 4 ] CVE-2021-21708
      https://nvd.nist.gov/vuln/detail/CVE-2021-21708
[ 5 ] CVE-2022-31625
      https://nvd.nist.gov/vuln/detail/CVE-2022-31625
[ 6 ] CVE-2022-31626
      https://nvd.nist.gov/vuln/detail/CVE-2022-31626
[ 7 ] CVE-2022-31627
      https://nvd.nist.gov/vuln/detail/CVE-2022-31627

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202209-20

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202209-20: PHP: Multiple Vulnerabilities

Summary

Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.

Resolution

All PHP 7.4 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-7.4.30:7.4"
All PHP 8.0 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-8.0.23:8.0"
All PHP 8.1 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-8.1.8:8.1"

References

[ 1 ] CVE-2021-21703 https://nvd.nist.gov/vuln/detail/CVE-2021-21703 [ 2 ] CVE-2021-21704 https://nvd.nist.gov/vuln/detail/CVE-2021-21704 [ 3 ] CVE-2021-21705 https://nvd.nist.gov/vuln/detail/CVE-2021-21705 [ 4 ] CVE-2021-21708 https://nvd.nist.gov/vuln/detail/CVE-2021-21708 [ 5 ] CVE-2022-31625 https://nvd.nist.gov/vuln/detail/CVE-2022-31625 [ 6 ] CVE-2022-31626 https://nvd.nist.gov/vuln/detail/CVE-2022-31626 [ 7 ] CVE-2022-31627 https://nvd.nist.gov/vuln/detail/CVE-2022-31627

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202209-20

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: PHP: Multiple Vulnerabilities
Date: September 29, 2022
Bugs: #799776, #810526, #819510, #833585, #850772, #857054
ID: 202209-20

Synopsis

Multiple vulnerabilities have been discovered in PHP, the worst of which could result in local root privilege escalation.

Background

PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-lang/php < 7.4.30:7.4 >= 7.4.30:7.4 < 8.0.23:8.0 >= 8.0.23:8.0 < 8.1.8:8.1 >= 8.1.8:8.1

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.