Gentoo: GLSA-202210-21: FasterXML jackson-databind: Multiple vulner...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202210-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Low
    Title: FasterXML jackson-databind: Multiple vulnerabilities
     Date: October 31, 2022
     Bugs: #874033
       ID: 202210-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in FasterXML jackson-databind,
the worst of which could result in denial of service.

Background
==========

FasterXML jackson-databind is a general data-binding package for Jackson
(2.x) which works on streaming API (core) implementation(s).

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-java/jackson-databind  < 2.13.4.1                >= 2.13.4.1

Description
===========

Multiple vulnerabilities have been discovered in FasterXML jackson-
databind. Please review the CVE identifiers referenced below for
details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All FasterXML jackson-databind users should upgrade to the latest
version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-java/jackson-databind-2.13.4.1"

References
==========

[ 1 ] CVE-2022-42003
      https://nvd.nist.gov/vuln/detail/CVE-2022-42003
[ 2 ] CVE-2022-42004
      https://nvd.nist.gov/vuln/detail/CVE-2022-42004

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202210-21

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202210-21: FasterXML jackson-databind: Multiple vulnerabilities

Summary

Multiple vulnerabilities have been discovered in FasterXML jackson- databind. Please review the CVE identifiers referenced below for details.

Resolution

All FasterXML jackson-databind users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-java/jackson-databind-2.13.4.1"

References

[ 1 ] CVE-2022-42003 https://nvd.nist.gov/vuln/detail/CVE-2022-42003 [ 2 ] CVE-2022-42004 https://nvd.nist.gov/vuln/detail/CVE-2022-42004

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202210-21

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: FasterXML jackson-databind: Multiple vulnerabilities
Date: October 31, 2022
Bugs: #874033
ID: 202210-21

Synopsis

Multiple vulnerabilities have been found in FasterXML jackson-databind, the worst of which could result in denial of service.

Background

FasterXML jackson-databind is a general data-binding package for Jackson (2.x) which works on streaming API (core) implementation(s).

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-java/jackson-databind < 2.13.4.1 >= 2.13.4.1

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.