MGASA-2020-0299 - Updated matio packages fix security vulnerability

Publication date: 31 Jul 2020
URL: https://advisories.mageia.org/MGASA-2020-0299.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2019-17533

Mat_VarReadNextInfo4 in mat4.c in MATIO 1.5.17 omits a certain '\0'
character, leading to a heap-based buffer over-read in strdup_vprintf
when uninitialized memory is accessed. (CVE-2019-17533)

References:
- https://bugs.mageia.org/show_bug.cgi?id=26883
- https://www.debian.org/lts/security/2020/dla-2267
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17533

SRPMS:
- 7/core/matio-1.5.16-1.1.mga7