MGASA-2021-0019 - Updated cherokee packages fix security vulnerability

Publication date: 10 Jan 2021
URL: https://advisories.mageia.org/MGASA-2021-0019.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2020-12845

Cherokee 0.4.27 to 1.2.104 is affected by a denial of service due to a NULL
pointer dereferences. A remote unauthenticated attacker can crash the server
by sending an HTTP request to protected resources using a malformed
Authorization header that is mishandled during a cherokee_buffer_add call
within cherokee_validator_parse_basic or cherokee_validator_parse_digest.
(CVE-2020-12845).

References:
- https://bugs.mageia.org/show_bug.cgi?id=27736
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12845

SRPMS:
- 7/core/cherokee-1.2.103-17.1.mga7