Linux Security
Linux Security
Linux Security

Mageia 2021-0077: nethack security update

Date 10 Feb 2021
125
Posted By LinuxSecurity Advisories
Updated nethack packages fix security vulnerabilities: NetHack 3.6.x before 3.6.4 is prone to a buffer overflow vulnerability when reading very long lines from configuration files. This affects systems that have NetHack installed suid/sgid, and shared systems that allow users to
MGASA-2021-0077 - Updated nethack packages fix security vulnerabilities

Publication date: 10 Feb 2021
URL: https://advisories.mageia.org/MGASA-2021-0077.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2019-19905,
     CVE-2020-5209,
     CVE-2020-5210,
     CVE-2020-5211,
     CVE-2020-5212,
     CVE-2020-5213,
     CVE-2020-5214,
     CVE-2020-5254

Updated nethack packages fix security vulnerabilities:

NetHack 3.6.x before 3.6.4 is prone to a buffer overflow vulnerability when
reading very long lines from configuration files. This affects systems that
have NetHack installed suid/sgid, and shared systems that allow users to
upload their own configuration files (CVE-2019-19905).

In NetHack before 3.6.5, unknown options starting with -de and -i can cause
a buffer overflow resulting in a crash or remote code execution/privilege
escalation. This vulnerability affects systems that have NetHack installed
suid/sgid and shared systems that allow users to influence command line
options (CVE-2020-5209).

In NetHack before 3.6.5, an invalid argument to the -w command line option
can cause a buffer overflow resulting in a crash or remote code
execution/privilege escalation. This vulnerability affects systems that have
NetHack installed suid/sgid and shared systems that allow users to influence
command line options (CVE-2020-5210).

In NetHack before 3.6.5, an invalid extended command in value for the
AUTOCOMPLETE configuration file option can cause a buffer overflow resulting
in a crash or remote code execution/privilege escalation. This vulnerability
affects systems that have NetHack installed suid/sgid and shared systems
that allow users to upload their own configuration files (CVE-2020-5211).

In NetHack before 3.6.5, an extremely long value for the MENUCOLOR
configuration file option can cause a buffer overflow resulting in a crash
or remote code execution/privilege escalation. This vulnerability affects
systems that have NetHack installed suid/sgid and shared systems that allow
users to upload their own configuration files (CVE-2020-5212).

In NetHack before 3.6.5, too long of a value for the SYMBOL configuration
file option can cause a buffer overflow resulting in a crash or remote code
execution/privilege escalation. This vulnerability affects systems that have
NetHack installed suid/sgid and shared systems that allow users to upload
their own configuration files (CVE-2020-5213).

In NetHack before 3.6.5, detecting an unknown configuration file option can
cause a buffer overflow resulting in a crash or remote code
execution/privilege escalation. This vulnerability affects systems that have
NetHack installed suid/sgid and shared systems that allow users to upload
their own configuration files (CVE-2020-5214).

In NetHack before 3.6.6, some out-of-bound values for the hilite_status
option can be exploited (CVE-2020-5254).

The nethack package has been updated to version 3.6.6, fixing these issues
and other bugs. See the upstream release notes for details.

References:
- https://bugs.mageia.org/show_bug.cgi?id=26228
- https://nethack.org/v362/release.html
- https://nethack.org/v363/release.html
- https://nethack.org/v364/release.html
- https://nethack.org/v365/release.html
- https://nethack.org/v366/release.html
- https://www.nethack.org/security/CVE-2019-19905.html
- https://www.nethack.org/security/CVE-2020-5209.html
- https://www.nethack.org/security/CVE-2020-5210.html
- https://www.nethack.org/security/CVE-2020-5211.html
- https://www.nethack.org/security/CVE-2020-5212.html
- https://www.nethack.org/security/CVE-2020-5213.html
- https://www.nethack.org/security/CVE-2020-5214.html
- https://www.nethack.org/security/CVE-2020-5254.html
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19905
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-5209
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-5210
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-5211
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-5212
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-5213
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-5214
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-5254

SRPMS:
- 7/core/nethack-3.6.6-1.mga7

LinuxSecurity Poll

How frequently do you patch/update your system?

No answer selected. Please try again.
Please select either existing option or enter your own, however not both.
Please select minimum 0 answer(s) and maximum 3 answer(s).
/main-polls/52-how-frequently-do-you-patch-update-your-system?task=poll.vote&format=json
52
radio
[{"id":"179","title":"As soon as patches\/updates are released - I track advisories for my distro(s) diligently","votes":"47","type":"x","order":"1","pct":79.66,"resources":[]},{"id":"180","title":"Every so often, when I think of it","votes":"7","type":"x","order":"2","pct":11.86,"resources":[]},{"id":"181","title":"Hardly ever","votes":"5","type":"x","order":"3","pct":8.47,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

Please vote first in order to view vote results.

VOTE ON THE POLL PAGE


VIEW MORE POLLS

bottom 200

Please enable / Bitte aktiviere JavaScript!
Veuillez activer / Por favor activa el Javascript![ ? ]

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.