MGASA-2021-0329 - Updated botan2 packages fix security vulnerability

Publication date: 10 Jul 2021
URL: https://advisories.mageia.org/MGASA-2021-0329.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2021-24115

Updated botan2 packages fix security vulnerability:

In Botan before 2.17.3, constant-time computations are not used for
certain decoding and encoding operations (base32, base58, base64, and
hex) (CVE-2021-24115).

References:
- https://bugs.mageia.org/show_bug.cgi?id=29057
- https://lists.opensuse.org/archives/list/[email protected]/thread/66VDUR6MFH345POI2NK4EL4N3NCJVT5O/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-24115

SRPMS:
- 7/core/botan2-2.9.0-2.2.mga7