MGASA-2021-0388 - Updated aspell packages fix security vulnerability

Publication date: 28 Jul 2021
URL: https://advisories.mageia.org/MGASA-2021-0388.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2019-25051

objstack in GNU Aspell 0.60.8 has a heap-based buffer overflow in
acommon::ObjStack::dup_top (called from acommon::StringMap::add and
acommon::Config::lookup_list) (CVE-2019-25051).

References:
- https://bugs.mageia.org/show_bug.cgi?id=29294
- https://ubuntu.com/security/notices/USN-5023-1
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-25051

SRPMS:
- 8/core/aspell-0.60.8-4.1.mga8