MGASA-2021-0414 - Updated libspf2 packages fix security vulnerability

Publication date: 04 Sep 2021
URL: https://advisories.mageia.org/MGASA-2021-0414.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-20314

A stack buffer overflow in libspf2 versions below 1.2.11 when processing 
certain SPF macros can lead to Denial of service and potentially code 
execution via malicious crafted SPF explanation messages (CVE-2021-20314). 

References:
- https://bugs.mageia.org/show_bug.cgi?id=29361
- https://www.openwall.com/lists/oss-security/2021/08/11/6
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-20314

SRPMS:
- 8/core/libspf2-1.2.10-5.1.mga8