Mageia 2022-0117: docker security update | LinuxSecurity.com
MGASA-2022-0117 - Updated docker packages fix security vulnerability

Publication date: 28 Mar 2022
URL: https://advisories.mageia.org/MGASA-2022-0117.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-24769

Containers were incorrectly started with non-empty inheritable Linux
process capabilities, creating an atypical Linux environment and enabling
programs with inheritable file capabilities to elevate those capabilities
to the permitted set during 'execve(2)' (CVE-2022-24769)

References:
- https://bugs.mageia.org/show_bug.cgi?id=30205
- https://docs.docker.com/engine/release-notes/#201014
- https://github.com/moby/moby/security/advisories/GHSA-2mm7-x5h6-5pvq
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24769

SRPMS:
- 8/core/docker-20.10.14-3.mga8

Mageia 2022-0117: docker security update

Summary

Containers were incorrectly started with non-empty inheritable Linux process capabilities, creating an atypical Linux environment and enabling programs with inheritable file capabilities to elevate those capabilities to the permitted set during 'execve(2)' (CVE-2022-24769)

References

- https://bugs.mageia.org/show_bug.cgi?id=30205

- https://docs.docker.com/engine/release-notes/#201014

- https://github.com/moby/moby/security/advisories/GHSA-2mm7-x5h6-5pvq

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24769

Resolution

MGASA-2022-0117 - Updated docker packages fix security vulnerability

SRPMS

- 8/core/docker-20.10.14-3.mga8

Severity
Publication date: 28 Mar 2022
URL: https://advisories.mageia.org/MGASA-2022-0117.html
Type: security
CVE: CVE-2022-24769

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.