MGASA-2022-0119 - Updated libtiff packages fix security vulnerability

Publication date: 28 Mar 2022
URL: https://advisories.mageia.org/MGASA-2022-0119.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-0865,
     CVE-2022-0891,
     CVE-2022-0908,
     CVE-2022-0909,
     CVE-2022-0924

Reachable Assertion in tiffcp in libtiff 4.3.0 allows attackers to cause a
denial-of-service via a crafted tiff file. (CVE-2022-0865)

A heap buffer overflow in ExtractImageSection function in tiffcrop.c in
libtiff library Version 4.3.0 allows attacker to trigger unsafe or out of
bounds memory access via crafted TIFF image file which could result into
application crash, potential information disclosure or any other
context-dependent impact. (CVE-2022-0891)

Null source pointer passed as an argument to memcpy() function within
TIFFFetchNormalTag () in tif_dirread.c in libtiff versions up to 4.3.0
could lead to Denial of Service via crafted TIFF file. (CVE-2022-0908)

Divide By Zero error in tiffcrop in libtiff 4.3.0 allows attackers to
cause a denial-of-service via a crafted tiff file. (CVE-2022-0909)

Out-of-bounds Read error in tiffcp in libtiff 4.3.0 allows attackers to
cause a denial-of-service via a crafted tiff file. (CVE-2022-0924)

References:
- https://bugs.mageia.org/show_bug.cgi?id=30210
- https://www.debian.org/security/2022/dsa-5108
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0865
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0891
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0908
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0909
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0924

SRPMS:
- 8/core/libtiff-4.2.0-1.3.mga8