MGASA-2022-0127 - Updated php-smarty packages fix security vulnerability

Publication date: 02 Apr 2022
URL: https://advisories.mageia.org/MGASA-2022-0127.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2018-13982,
     CVE-2018-16831,
     CVE-2021-21408,
     CVE-2021-26119,
     CVE-2021-26120,
     CVE-2021-29454

Updated php-smarty packages to version 4 for php 8 compatibility and to
fix security vulnerabilities.

References:
- https://bugs.mageia.org/show_bug.cgi?id=30214
- https://ubuntu.com/security/notices/USN-5348-1
- https://github.com/smarty-php/smarty/releases/tag/v4.0.4
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-13982
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-16831
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21408
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-26119
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-26120
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29454

SRPMS:
- 8/core/php-smarty-4.0.4-1.mga8