MGASA-2022-0137 - Updated gdal packages fix security vulnerability

Publication date: 09 Apr 2022
URL: https://advisories.mageia.org/MGASA-2022-0137.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-45943

GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in
PCIDSK::CPCIDSKFile::ReadFromFile (called from
PCIDSK::CPCIDSKSegment::ReadFromFile and
PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment). (CVE-2021-45943)

References:
- https://bugs.mageia.org/show_bug.cgi?id=30256
- https://lists.fedoraproject.org/archives/list/[email protected]/thread/P23E4DEHY5FJCR5VJ46I6TO32DT7Y3T4/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-45943

SRPMS:
- 8/core/gdal-3.1.3-7.2.mga8