Mageia 2022-0269: gdk-pixbuf2.0 security update | LinuxSecurity.com

Advisories

MGASA-2022-0269 - Updated gdk-pixbuf2.0 packages fix security vulnerability

Publication date: 29 Jul 2022
URL: https://advisories.mageia.org/MGASA-2022-0269.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-46829

It was discovered that gdk-pixbuf contained a buffer overwrite in    
io-gif-animation.c composite_frame() exploitable using a crafted GIF
(CVE-2021-46829).

References:
- https://bugs.mageia.org/show_bug.cgi?id=30662
- https://www.openwall.com/lists/oss-security/2022/07/23/1
- https://www.openwall.com/lists/oss-security/2022/07/25/1
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-46829

SRPMS:
- 8/core/gdk-pixbuf2.0-2.42.2-1.1.mga8

Mageia 2022-0269: gdk-pixbuf2.0 security update

It was discovered that gdk-pixbuf contained a buffer overwrite in io-gif-animation.c composite_frame() exploitable using a crafted GIF (CVE-2021-46829)

Summary

It was discovered that gdk-pixbuf contained a buffer overwrite in io-gif-animation.c composite_frame() exploitable using a crafted GIF (CVE-2021-46829).

References

- https://bugs.mageia.org/show_bug.cgi?id=30662

- https://www.openwall.com/lists/oss-security/2022/07/23/1

- https://www.openwall.com/lists/oss-security/2022/07/25/1

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-46829

Resolution

MGASA-2022-0269 - Updated gdk-pixbuf2.0 packages fix security vulnerability

SRPMS

- 8/core/gdk-pixbuf2.0-2.42.2-1.1.mga8

Severity
Publication date: 29 Jul 2022
URL: https://advisories.mageia.org/MGASA-2022-0269.html
Type: security
CVE: CVE-2021-46829

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.