Mageia 2022-0275: mingw-giflib security update | LinuxSecurity.com

Advisories

MGASA-2022-0275 - Updated mingw-giflib packages fix security vulnerability

Publication date: 05 Aug 2022
URL: https://advisories.mageia.org/MGASA-2022-0275.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-28506

It was discovered that giflib 5.2.1 (including mingw-giflib which has
giflib 5.2.1 bundled) contained a heap-buffer-overflow in function
DumpScreen2RGB() (CVE-2022-28506).

References:
- https://bugs.mageia.org/show_bug.cgi?id=30671
- https://lists.fedoraproject.org/archives/list/[email protected]/thread/B4CJSHXBD2RS5OJNWSHQZVMTQCCTIPYS/
- https://sourceforge.net/p/giflib/bugs/159/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28506

SRPMS:
- 8/core/mingw-giflib-5.2.1-2.1.mga8
- 8/core/giflib-5.2.1-5.1.mga8

Mageia 2022-0275: mingw-giflib security update

It was discovered that giflib 5.2.1 (including mingw-giflib which has giflib 5.2.1 bundled) contained a heap-buffer-overflow in function DumpScreen2RGB() (CVE-2022-28506)

Summary

It was discovered that giflib 5.2.1 (including mingw-giflib which has giflib 5.2.1 bundled) contained a heap-buffer-overflow in function DumpScreen2RGB() (CVE-2022-28506).

References

- https://bugs.mageia.org/show_bug.cgi?id=30671

- https://lists.fedoraproject.org/archives/list/[email protected]/thread/B4CJSHXBD2RS5OJNWSHQZVMTQCCTIPYS/

- https://sourceforge.net/p/giflib/bugs/159/

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28506

Resolution

MGASA-2022-0275 - Updated mingw-giflib packages fix security vulnerability

SRPMS

- 8/core/mingw-giflib-5.2.1-2.1.mga8

- 8/core/giflib-5.2.1-5.1.mga8

Severity
Publication date: 05 Aug 2022
URL: https://advisories.mageia.org/MGASA-2022-0275.html
Type: security
CVE: CVE-2022-28506

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.