Mageia 2022-0301: gnutls security update | LinuxSecurity.com

Advisories

MGASA-2022-0301 - Updated gnutls packages fix security vulnerability

Publication date: 25 Aug 2022
URL: https://advisories.mageia.org/MGASA-2022-0301.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-2509

A double free error occurs during verification of pkcs7 signatures in
gnutls_pkcs7_verify function. (CVE-2022-2509)

References:
- https://bugs.mageia.org/show_bug.cgi?id=30691
- https://lists.fedoraproject.org/archives/list/[email protected]/thread/5NRKG3OBVPVFJTDYYF6SZH5KZIWFLVPW/
- https://www.gnutls.org/security-new.html#GNUTLS-SA-2022-07-07
- https://ubuntu.com/security/notices/USN-5550-1
- https://www.debian.org/security/2022/dsa-5203
- https://lists.suse.com/pipermail/sle-security-updates/2022-August/011930.html
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-2509

SRPMS:
- 8/core/gnutls-3.6.15-3.3.mga8

Mageia 2022-0301: gnutls security update

A double free error occurs during verification of pkcs7 signatures in gnutls_pkcs7_verify function

Summary

A double free error occurs during verification of pkcs7 signatures in gnutls_pkcs7_verify function. (CVE-2022-2509)

References

- https://bugs.mageia.org/show_bug.cgi?id=30691

- https://lists.fedoraproject.org/archives/list/[email protected]/thread/5NRKG3OBVPVFJTDYYF6SZH5KZIWFLVPW/

- https://www.gnutls.org/security-new.html#GNUTLS-SA-2022-07-07

- https://ubuntu.com/security/notices/USN-5550-1

- https://www.debian.org/security/2022/dsa-5203

- https://lists.suse.com/pipermail/sle-security-updates/2022-August/011930.html

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-2509

Resolution

MGASA-2022-0301 - Updated gnutls packages fix security vulnerability

SRPMS

- 8/core/gnutls-3.6.15-3.3.mga8

Severity
Publication date: 25 Aug 2022
URL: https://advisories.mageia.org/MGASA-2022-0301.html
Type: security
CVE: CVE-2022-2509

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.