Mageia 2022-0464: vim security update | LinuxSecurity.com
MGASA-2022-0464 - Updated vim packages fix security vulnerability

Publication date: 13 Dec 2022
URL: https://advisories.mageia.org/MGASA-2022-0464.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-4141

Heap based buffer overflow in vim/vim 9.0.0946 and below by allowing an
attacker to CTRL-W gf in the expression used in the RHS of the substitute
command. (CVE-2022-4141)

References:
- https://bugs.mageia.org/show_bug.cgi?id=31239
- https://lists.fedoraproject.org/archives/list/[email protected]/thread/AZ3JMSUCR6Y7626RDWQ2HNSUFIQOJ33G/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-4141

SRPMS:
- 8/core/vim-9.0.963-1.mga8

Mageia 2022-0464: vim security update

Heap based buffer overflow in vim/vim 9.0.0946 and below by allowing an attacker to CTRL-W gf in the expression used in the RHS of the substitute command

Summary

Heap based buffer overflow in vim/vim 9.0.0946 and below by allowing an attacker to CTRL-W gf in the expression used in the RHS of the substitute command. (CVE-2022-4141)

References

- https://bugs.mageia.org/show_bug.cgi?id=31239

- https://lists.fedoraproject.org/archives/list/[email protected]/thread/AZ3JMSUCR6Y7626RDWQ2HNSUFIQOJ33G/

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-4141

Resolution

MGASA-2022-0464 - Updated vim packages fix security vulnerability

SRPMS

- 8/core/vim-9.0.963-1.mga8

Severity
Publication date: 13 Dec 2022
URL: https://advisories.mageia.org/MGASA-2022-0464.html
Type: security
CVE: CVE-2022-4141

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.