Mageia 2023-0006: w3m security update | LinuxSecurity.com
MGASA-2023-0006 - Updated w3m packages fix security vulnerability

Publication date: 13 Jan 2023
URL: https://advisories.mageia.org/MGASA-2023-0006.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-38223

There is an out-of-bounds write in checkType located in etc.c in w3m
0.5.3. It can be triggered by sending a crafted HTML file to the w3m
binary. It allows an attacker to cause Denial of Service or possibly have
unspecified other impact. (CVE-2022-38223)

References:
- https://bugs.mageia.org/show_bug.cgi?id=31365
- https://lists.fedoraproject.org/archives/list/[email protected]/thread/NRRZMTLG3YT6U3PSGJOAMLDNLRF2EUOP/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-38223

SRPMS:
- 8/core/w3m-0.5.3-13.git20220429.1.mga8

Mageia 2023-0006: w3m security update

There is an out-of-bounds write in checkType located in etc.c in w3m 0.5.3

Summary

There is an out-of-bounds write in checkType located in etc.c in w3m 0.5.3. It can be triggered by sending a crafted HTML file to the w3m binary. It allows an attacker to cause Denial of Service or possibly have unspecified other impact. (CVE-2022-38223)

References

- https://bugs.mageia.org/show_bug.cgi?id=31365

- https://lists.fedoraproject.org/archives/list/[email protected]/thread/NRRZMTLG3YT6U3PSGJOAMLDNLRF2EUOP/

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-38223

Resolution

MGASA-2023-0006 - Updated w3m packages fix security vulnerability

SRPMS

- 8/core/w3m-0.5.3-13.git20220429.1.mga8

Severity
Publication date: 13 Jan 2023
URL: https://advisories.mageia.org/MGASA-2023-0006.html
Type: security
CVE: CVE-2022-38223

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.