openSUSE Security Update: Security update for libgit2
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2018:2502-1
Rating:             important
References:         #1095219 #1100612 #1100613 #1104641 
Cross-References:   CVE-2018-10887 CVE-2018-10888 CVE-2018-11235
                    CVE-2018-15501
Affected Products:
                    openSUSE Leap 15.0
______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:

   This update for libgit2 to version 0.26.5 fixes the following issues:

   The following security vulnerabilities were addressed:

   - CVE-2018-10887: Fixed an integer overflow which in turn leads to an out
     of bound read, allowing to read the base object, which could be
     exploited by an attacker to cause denial of service (DoS) (bsc#1100613).
   - CVE-2018-10888: Fixed an out-of-bound read while reading a binary delta
     file, which could be exploited by an attacker t ocause a denial of
     service (DoS) (bsc#1100612).
   - CVE-2018-11235: Fixed a remote code execution, which could occur with a
     crafted .gitmodules file (bsc#1095219)
   - CVE-2018-15501: Prevent out-of-bounds reads when processing
     smart-protocol "ng" packets (bsc#1104641)

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.0:

      zypper in -t patch openSUSE-2018-922=1



Package List:

   - openSUSE Leap 15.0 (i586 x86_64):

      libgit2-26-0.26.6-lp150.2.3.1
      libgit2-26-debuginfo-0.26.6-lp150.2.3.1
      libgit2-debugsource-0.26.6-lp150.2.3.1
      libgit2-devel-0.26.6-lp150.2.3.1

   - openSUSE Leap 15.0 (x86_64):

      libgit2-26-32bit-0.26.6-lp150.2.3.1
      libgit2-26-32bit-debuginfo-0.26.6-lp150.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2018-10887.html
   https://www.suse.com/security/cve/CVE-2018-10888.html
   https://www.suse.com/security/cve/CVE-2018-11235.html
   https://www.suse.com/security/cve/CVE-2018-15501.html
   https://bugzilla.suse.com/1095219
   https://bugzilla.suse.com/1100612
   https://bugzilla.suse.com/1100613
   https://bugzilla.suse.com/1104641

-- 

openSUSE: 2018:2502-1: important: libgit2

August 25, 2018
An update that fixes four vulnerabilities is now available.

Description

This update for libgit2 to version 0.26.5 fixes the following issues: The following security vulnerabilities were addressed: - CVE-2018-10887: Fixed an integer overflow which in turn leads to an out of bound read, allowing to read the base object, which could be exploited by an attacker to cause denial of service (DoS) (bsc#1100613). - CVE-2018-10888: Fixed an out-of-bound read while reading a binary delta file, which could be exploited by an attacker t ocause a denial of service (DoS) (bsc#1100612). - CVE-2018-11235: Fixed a remote code execution, which could occur with a crafted .gitmodules file (bsc#1095219) - CVE-2018-15501: Prevent out-of-bounds reads when processing smart-protocol "ng" packets (bsc#1104641) This update was imported from the SUSE:SLE-15:Update update project.

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.0: zypper in -t patch openSUSE-2018-922=1


Package List

- openSUSE Leap 15.0 (i586 x86_64): libgit2-26-0.26.6-lp150.2.3.1 libgit2-26-debuginfo-0.26.6-lp150.2.3.1 libgit2-debugsource-0.26.6-lp150.2.3.1 libgit2-devel-0.26.6-lp150.2.3.1 - openSUSE Leap 15.0 (x86_64): libgit2-26-32bit-0.26.6-lp150.2.3.1 libgit2-26-32bit-debuginfo-0.26.6-lp150.2.3.1


References

https://www.suse.com/security/cve/CVE-2018-10887.html https://www.suse.com/security/cve/CVE-2018-10888.html https://www.suse.com/security/cve/CVE-2018-11235.html https://www.suse.com/security/cve/CVE-2018-15501.html https://bugzilla.suse.com/1095219 https://bugzilla.suse.com/1100612 https://bugzilla.suse.com/1100613 https://bugzilla.suse.com/1104641--


Severity
Announcement ID: openSUSE-SU-2018:2502-1
Rating: important
Affected Products: openSUSE Leap 15.0