openSUSE: 2019:1580-1: important: python

    Date18 Jun 2019
    CategoryopenSUSE
    389
    Posted ByLinuxSecurity Advisories
    An update that fixes two vulnerabilities is now available.
       openSUSE Security Update: Security update for python
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:1580-1
    Rating:             important
    References:         #1129346 #1130847 
    Cross-References:   CVE-2019-9636 CVE-2019-9948
    Affected Products:
                        openSUSE Leap 42.3
    ______________________________________________________________________________
    
       An update that fixes two vulnerabilities is now available.
    
    Description:
    
       This update for python fixes the following issues:
    
       Security issues fixed:
    
       - CVE-2019-9948: Fixed a 'file:' blacklist bypass in URIs by using the
         'local-file:' scheme instead (bsc#1130847).
       - CVE-2019-9636: Fixed an information disclosure because of incorrect
         handling of Unicode encoding during NFKC normalization (bsc#1129346).
    
       This update was imported from the SUSE:SLE-12-SP1:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 42.3:
    
          zypper in -t patch openSUSE-2019-1580=1
    
    
    
    Package List:
    
       - openSUSE Leap 42.3 (i586 x86_64):
    
          libpython2_7-1_0-2.7.13-27.15.1
          libpython2_7-1_0-debuginfo-2.7.13-27.15.1
          python-2.7.13-27.15.1
          python-base-2.7.13-27.15.1
          python-base-debuginfo-2.7.13-27.15.1
          python-base-debugsource-2.7.13-27.15.1
          python-curses-2.7.13-27.15.1
          python-curses-debuginfo-2.7.13-27.15.1
          python-debuginfo-2.7.13-27.15.1
          python-debugsource-2.7.13-27.15.1
          python-demo-2.7.13-27.15.1
          python-devel-2.7.13-27.15.1
          python-gdbm-2.7.13-27.15.1
          python-gdbm-debuginfo-2.7.13-27.15.1
          python-idle-2.7.13-27.15.1
          python-tk-2.7.13-27.15.1
          python-tk-debuginfo-2.7.13-27.15.1
          python-xml-2.7.13-27.15.1
          python-xml-debuginfo-2.7.13-27.15.1
    
       - openSUSE Leap 42.3 (x86_64):
    
          libpython2_7-1_0-32bit-2.7.13-27.15.1
          libpython2_7-1_0-debuginfo-32bit-2.7.13-27.15.1
          python-32bit-2.7.13-27.15.1
          python-base-32bit-2.7.13-27.15.1
          python-base-debuginfo-32bit-2.7.13-27.15.1
          python-debuginfo-32bit-2.7.13-27.15.1
    
       - openSUSE Leap 42.3 (noarch):
    
          python-doc-2.7.13-27.15.1
          python-doc-pdf-2.7.13-27.15.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-9636.html
       https://www.suse.com/security/cve/CVE-2019-9948.html
       https://bugzilla.suse.com/1129346
       https://bugzilla.suse.com/1130847
    
    -- 
    

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"15","type":"x","order":"1","pct":53.57,"resources":[]},{"id":"88","title":"Should be more technical","votes":"4","type":"x","order":"2","pct":14.29,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"9","type":"x","order":"3","pct":32.14,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.