openSUSE: 2019:1855-1: important: kconfig, kdelibs4

    Date 13 Aug 2019
    448
    Posted By LinuxSecurity Advisories
    An update that fixes one vulnerability is now available.
       openSUSE Security Update: Security update for kconfig, kdelibs4
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:1855-1
    Rating:             important
    References:         #1144600 
    Cross-References:   CVE-2019-14744
    Affected Products:
                        openSUSE Backports SLE-15
    ______________________________________________________________________________
    
       An update that fixes one vulnerability is now available.
    
    Description:
    
       This update for kconfig, kdelibs4 fixes the following issues:
    
       - CVE-2019-14744: Fixed a command execution by an shell expansion
         (boo#1144600).
    
       This update was imported from the openSUSE:Leap:15.0:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Backports SLE-15:
    
          zypper in -t patch openSUSE-2019-1855=1
    
    
    
    Package List:
    
       - openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):
    
          kconf_update5-5.45.0-bp150.3.8.2
          kconf_update5-debuginfo-5.45.0-bp150.3.8.2
          kconfig-debugsource-5.45.0-bp150.3.8.2
          kconfig-devel-5.45.0-bp150.3.8.2
          kconfig-devel-debuginfo-5.45.0-bp150.3.8.2
          kdelibs4-4.14.38-bp150.3.8.1
          kdelibs4-branding-upstream-4.14.38-bp150.3.8.1
          kdelibs4-core-4.14.38-bp150.3.8.1
          kdelibs4-doc-4.14.38-bp150.3.8.1
          libKF5ConfigCore5-5.45.0-bp150.3.8.2
          libKF5ConfigCore5-debuginfo-5.45.0-bp150.3.8.2
          libKF5ConfigGui5-5.45.0-bp150.3.8.2
          libKF5ConfigGui5-debuginfo-5.45.0-bp150.3.8.2
          libkde4-4.14.38-bp150.3.8.1
          libkde4-devel-4.14.38-bp150.3.8.1
          libkdecore4-4.14.38-bp150.3.8.1
          libkdecore4-devel-4.14.38-bp150.3.8.1
          libksuseinstall-devel-4.14.38-bp150.3.8.1
          libksuseinstall1-4.14.38-bp150.3.8.1
    
       - openSUSE Backports SLE-15 (aarch64_ilp32):
    
          kconfig-devel-64bit-5.45.0-bp150.3.8.2
          kconfig-devel-64bit-debuginfo-5.45.0-bp150.3.8.2
          libKF5ConfigCore5-64bit-5.45.0-bp150.3.8.2
          libKF5ConfigCore5-64bit-debuginfo-5.45.0-bp150.3.8.2
          libKF5ConfigGui5-64bit-5.45.0-bp150.3.8.2
          libKF5ConfigGui5-64bit-debuginfo-5.45.0-bp150.3.8.2
          libkde4-64bit-4.14.38-bp150.3.8.1
          libkdecore4-64bit-4.14.38-bp150.3.8.1
          libksuseinstall1-64bit-4.14.38-bp150.3.8.1
    
       - openSUSE Backports SLE-15 (noarch):
    
          kdelibs4-apidocs-4.14.38-bp150.3.8.1
          libKF5ConfigCore5-lang-5.45.0-bp150.3.8.2
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-14744.html
       https://bugzilla.suse.com/1144600
    
    -- 
    

    LinuxSecurity Poll

    Do you feel that the Lawful Access to Encrypted Data Act, which aims to force encryption backdoors, is a threat to US citizens' privacy?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/30-do-you-feel-that-the-lawful-access-to-encrypted-data-act-which-aims-to-force-encryption-backdoors-is-a-threat-to-privacy?task=poll.vote&format=json
    30
    radio
    [{"id":"106","title":"Yes - I am a privacy advocate and I am strongly opposed to this bill.","votes":"23","type":"x","order":"1","pct":95.83,"resources":[]},{"id":"107","title":"I'm undecided - it has its pros and cons.","votes":"1","type":"x","order":"2","pct":4.17,"resources":[]},{"id":"108","title":"No - I support this bill and feel that it will help protect against crime and threats to our national security. ","votes":"0","type":"x","order":"3","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.