openSUSE: 2019:2149-1: important: curl

    Date 17 Sep 2019
    685
    Posted By LinuxSecurity Advisories
    An update that fixes two vulnerabilities is now available.
       openSUSE Security Update: Security update for curl
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:2149-1
    Rating:             important
    References:         #1149495 #1149496 
    Cross-References:   CVE-2019-5481 CVE-2019-5482
    Affected Products:
                        openSUSE Leap 15.1
    ______________________________________________________________________________
    
       An update that fixes two vulnerabilities is now available.
    
    Description:
    
       This update for curl fixes the following issues:
    
       Security issues fixed:
    
       - CVE-2019-5481: Fixed FTP-KRB double-free during kerberos FTP data
         transfer (bsc#1149495).
       - CVE-2019-5482: Fixed TFTP small blocksize heap buffer overflow
         (bsc#1149496).
    
       This update was imported from the SUSE:SLE-15:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2019-2149=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.1 (i586 x86_64):
    
          curl-7.60.0-lp151.5.6.1
          curl-debuginfo-7.60.0-lp151.5.6.1
          curl-debugsource-7.60.0-lp151.5.6.1
          curl-mini-7.60.0-lp151.5.6.1
          curl-mini-debuginfo-7.60.0-lp151.5.6.1
          curl-mini-debugsource-7.60.0-lp151.5.6.1
          libcurl-devel-7.60.0-lp151.5.6.1
          libcurl-mini-devel-7.60.0-lp151.5.6.1
          libcurl4-7.60.0-lp151.5.6.1
          libcurl4-debuginfo-7.60.0-lp151.5.6.1
          libcurl4-mini-7.60.0-lp151.5.6.1
          libcurl4-mini-debuginfo-7.60.0-lp151.5.6.1
    
       - openSUSE Leap 15.1 (x86_64):
    
          libcurl-devel-32bit-7.60.0-lp151.5.6.1
          libcurl4-32bit-7.60.0-lp151.5.6.1
          libcurl4-32bit-debuginfo-7.60.0-lp151.5.6.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-5481.html
       https://www.suse.com/security/cve/CVE-2019-5482.html
       https://bugzilla.suse.com/1149495
       https://bugzilla.suse.com/1149496
    
    -- 
    

    LinuxSecurity Poll

    If you are using full-disk encryption: are you concerned about the resulting performance hit?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/34-if-you-are-using-full-disk-encryption-are-you-concerned-about-the-resulting-performance-hit?task=poll.vote&format=json
    34
    radio
    [{"id":"120","title":"Yes","votes":"13","type":"x","order":"1","pct":59.09,"resources":[]},{"id":"121","title":"No ","votes":"9","type":"x","order":"2","pct":40.91,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.