openSUSE: 2019:2420-1: important: chromium, re2

    Date 01 Nov 2019
    476
    Posted By LinuxSecurity Advisories
    An update that fixes 21 vulnerabilities is now available.
       openSUSE Security Update: Security update for chromium, re2
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2019:2420-1
    Rating:             important
    References:         #1154806 
    Cross-References:   CVE-2019-13699 CVE-2019-13700 CVE-2019-13701
                        CVE-2019-13702 CVE-2019-13703 CVE-2019-13704
                        CVE-2019-13705 CVE-2019-13706 CVE-2019-13707
                        CVE-2019-13708 CVE-2019-13709 CVE-2019-13710
                        CVE-2019-13711 CVE-2019-13713 CVE-2019-13714
                        CVE-2019-13715 CVE-2019-13716 CVE-2019-13717
                        CVE-2019-13718 CVE-2019-13719 CVE-2019-15903
                       
    Affected Products:
                        openSUSE Leap 15.1
                        openSUSE Leap 15.0
    ______________________________________________________________________________
    
       An update that fixes 21 vulnerabilities is now available.
    
    Description:
    
       This update for chromium, re2 fixes the following issues:
    
       Chromium was updated to 78.0.3904.70 boo#1154806:
    
       * CVE-2019-13699: Use-after-free in media
       * CVE-2019-13700: Buffer overrun in Blink
       * CVE-2019-13701: URL spoof in navigation
       * CVE-2019-13702: Privilege elevation in Installer
       * CVE-2019-13703: URL bar spoofing
       * CVE-2019-13704: CSP bypass
       * CVE-2019-13705: Extension permission bypass
       * CVE-2019-13706: Out-of-bounds read in PDFium
       * CVE-2019-13707: File storage disclosure
       * CVE-2019-13708: HTTP authentication spoof
       * CVE-2019-13709: File download protection bypass
       * CVE-2019-13710: File download protection bypass
       * CVE-2019-13711: Cross-context information leak
       * CVE-2019-15903: Buffer overflow in expat
       * CVE-2019-13713: Cross-origin data leak
       * CVE-2019-13714: CSS injection
       * CVE-2019-13715: Address bar spoofing
       * CVE-2019-13716: Service worker state error
       * CVE-2019-13717: Notification obscured
       * CVE-2019-13718: IDN spoof
       * CVE-2019-13719: Notification obscured
       * Various fixes from internal audits, fuzzing and other initiatives
    
       - Use internal resources for icon and appdata
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2019-2420=1
    
       - openSUSE Leap 15.0:
    
          zypper in -t patch openSUSE-2019-2420=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.1 (i586 x86_64):
    
          libre2-0-20190901-lp151.10.3.1
          libre2-0-debuginfo-20190901-lp151.10.3.1
          re2-debugsource-20190901-lp151.10.3.1
          re2-devel-20190901-lp151.10.3.1
    
       - openSUSE Leap 15.1 (x86_64):
    
          chromedriver-78.0.3904.70-lp151.2.39.1
          chromedriver-debuginfo-78.0.3904.70-lp151.2.39.1
          chromium-78.0.3904.70-lp151.2.39.1
          chromium-debuginfo-78.0.3904.70-lp151.2.39.1
          chromium-debugsource-78.0.3904.70-lp151.2.39.1
          libre2-0-32bit-20190901-lp151.10.3.1
          libre2-0-32bit-debuginfo-20190901-lp151.10.3.1
    
       - openSUSE Leap 15.0 (i586 x86_64):
    
          libre2-0-20190901-lp150.25.1
          libre2-0-debuginfo-20190901-lp150.25.1
          re2-debugsource-20190901-lp150.25.1
          re2-devel-20190901-lp150.25.1
    
       - openSUSE Leap 15.0 (x86_64):
    
          chromedriver-78.0.3904.70-lp150.248.2
          chromedriver-debuginfo-78.0.3904.70-lp150.248.2
          chromium-78.0.3904.70-lp150.248.2
          chromium-debuginfo-78.0.3904.70-lp150.248.2
          chromium-debugsource-78.0.3904.70-lp150.248.2
          libre2-0-32bit-20190901-lp150.25.1
          libre2-0-32bit-debuginfo-20190901-lp150.25.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-13699.html
       https://www.suse.com/security/cve/CVE-2019-13700.html
       https://www.suse.com/security/cve/CVE-2019-13701.html
       https://www.suse.com/security/cve/CVE-2019-13702.html
       https://www.suse.com/security/cve/CVE-2019-13703.html
       https://www.suse.com/security/cve/CVE-2019-13704.html
       https://www.suse.com/security/cve/CVE-2019-13705.html
       https://www.suse.com/security/cve/CVE-2019-13706.html
       https://www.suse.com/security/cve/CVE-2019-13707.html
       https://www.suse.com/security/cve/CVE-2019-13708.html
       https://www.suse.com/security/cve/CVE-2019-13709.html
       https://www.suse.com/security/cve/CVE-2019-13710.html
       https://www.suse.com/security/cve/CVE-2019-13711.html
       https://www.suse.com/security/cve/CVE-2019-13713.html
       https://www.suse.com/security/cve/CVE-2019-13714.html
       https://www.suse.com/security/cve/CVE-2019-13715.html
       https://www.suse.com/security/cve/CVE-2019-13716.html
       https://www.suse.com/security/cve/CVE-2019-13717.html
       https://www.suse.com/security/cve/CVE-2019-13718.html
       https://www.suse.com/security/cve/CVE-2019-13719.html
       https://www.suse.com/security/cve/CVE-2019-15903.html
       https://bugzilla.suse.com/1154806
    
    -- 
    

    LinuxSecurity Poll

    Do you feel that the Lawful Access to Encrypted Data Act, which aims to force encryption backdoors, is a threat to US citizens' privacy?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/30-do-you-feel-that-the-lawful-access-to-encrypted-data-act-which-aims-to-force-encryption-backdoors-is-a-threat-to-privacy?task=poll.vote&format=json
    30
    radio
    [{"id":"106","title":"Yes - I am a privacy advocate and I am strongly opposed to this bill.","votes":"7","type":"x","order":"1","pct":100,"resources":[]},{"id":"107","title":"I'm undecided - it has its pros and cons.","votes":"0","type":"x","order":"2","pct":0,"resources":[]},{"id":"108","title":"No - I support this bill and feel that it will help protect against crime and threats to our national security. ","votes":"0","type":"x","order":"3","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.