openSUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:1256-1
Rating:             important
References:         #1174662 
Cross-References:   CVE-2020-9862 CVE-2020-9893 CVE-2020-9894
                    CVE-2020-9895 CVE-2020-9915 CVE-2020-9925
                   
Affected Products:
                    openSUSE Leap 15.1
______________________________________________________________________________

   An update that fixes 6 vulnerabilities is now available.

Description:

   This update for webkit2gtk3 fixes the following issues:

   - Update to version 2.28.4 (bsc#1174662):
     + Fix several crashes and rendering issues.
     + Security fixes: CVE-2020-9862, CVE-2020-9893, CVE-2020-9894,
       CVE-2020-9895, CVE-2020-9915, CVE-2020-9925.

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.1:

      zypper in -t patch openSUSE-2020-1256=1



Package List:

   - openSUSE Leap 15.1 (i586 x86_64):

      libjavascriptcoregtk-4_0-18-2.28.4-lp151.2.24.3
      libjavascriptcoregtk-4_0-18-debuginfo-2.28.4-lp151.2.24.3
      libwebkit2gtk-4_0-37-2.28.4-lp151.2.24.3
      libwebkit2gtk-4_0-37-debuginfo-2.28.4-lp151.2.24.3
      typelib-1_0-JavaScriptCore-4_0-2.28.4-lp151.2.24.3
      typelib-1_0-WebKit2-4_0-2.28.4-lp151.2.24.3
      typelib-1_0-WebKit2WebExtension-4_0-2.28.4-lp151.2.24.3
      webkit-jsc-4-2.28.4-lp151.2.24.3
      webkit-jsc-4-debuginfo-2.28.4-lp151.2.24.3
      webkit2gtk-4_0-injected-bundles-2.28.4-lp151.2.24.3
      webkit2gtk-4_0-injected-bundles-debuginfo-2.28.4-lp151.2.24.3
      webkit2gtk3-debugsource-2.28.4-lp151.2.24.3
      webkit2gtk3-devel-2.28.4-lp151.2.24.3
      webkit2gtk3-minibrowser-2.28.4-lp151.2.24.3
      webkit2gtk3-minibrowser-debuginfo-2.28.4-lp151.2.24.3

   - openSUSE Leap 15.1 (x86_64):

      libjavascriptcoregtk-4_0-18-32bit-2.28.4-lp151.2.24.3
      libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.28.4-lp151.2.24.3
      libwebkit2gtk-4_0-37-32bit-2.28.4-lp151.2.24.3
      libwebkit2gtk-4_0-37-32bit-debuginfo-2.28.4-lp151.2.24.3

   - openSUSE Leap 15.1 (noarch):

      libwebkit2gtk3-lang-2.28.4-lp151.2.24.3


References:

   https://www.suse.com/security/cve/CVE-2020-9862.html
   https://www.suse.com/security/cve/CVE-2020-9893.html
   https://www.suse.com/security/cve/CVE-2020-9894.html
   https://www.suse.com/security/cve/CVE-2020-9895.html
   https://www.suse.com/security/cve/CVE-2020-9915.html
   https://www.suse.com/security/cve/CVE-2020-9925.html
   https://bugzilla.suse.com/1174662

-- 

openSUSE: 2020:1256-1: important: webkit2gtk3

August 24, 2020
An update that fixes 6 vulnerabilities is now available.

Description

This update for webkit2gtk3 fixes the following issues: - Update to version 2.28.4 (bsc#1174662): + Fix several crashes and rendering issues. + Security fixes: CVE-2020-9862, CVE-2020-9893, CVE-2020-9894, CVE-2020-9895, CVE-2020-9915, CVE-2020-9925. This update was imported from the SUSE:SLE-15:Update update project.

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.1: zypper in -t patch openSUSE-2020-1256=1


Package List

- openSUSE Leap 15.1 (i586 x86_64): libjavascriptcoregtk-4_0-18-2.28.4-lp151.2.24.3 libjavascriptcoregtk-4_0-18-debuginfo-2.28.4-lp151.2.24.3 libwebkit2gtk-4_0-37-2.28.4-lp151.2.24.3 libwebkit2gtk-4_0-37-debuginfo-2.28.4-lp151.2.24.3 typelib-1_0-JavaScriptCore-4_0-2.28.4-lp151.2.24.3 typelib-1_0-WebKit2-4_0-2.28.4-lp151.2.24.3 typelib-1_0-WebKit2WebExtension-4_0-2.28.4-lp151.2.24.3 webkit-jsc-4-2.28.4-lp151.2.24.3 webkit-jsc-4-debuginfo-2.28.4-lp151.2.24.3 webkit2gtk-4_0-injected-bundles-2.28.4-lp151.2.24.3 webkit2gtk-4_0-injected-bundles-debuginfo-2.28.4-lp151.2.24.3 webkit2gtk3-debugsource-2.28.4-lp151.2.24.3 webkit2gtk3-devel-2.28.4-lp151.2.24.3 webkit2gtk3-minibrowser-2.28.4-lp151.2.24.3 webkit2gtk3-minibrowser-debuginfo-2.28.4-lp151.2.24.3 - openSUSE Leap 15.1 (x86_64): libjavascriptcoregtk-4_0-18-32bit-2.28.4-lp151.2.24.3 libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.28.4-lp151.2.24.3 libwebkit2gtk-4_0-37-32bit-2.28.4-lp151.2.24.3 libwebkit2gtk-4_0-37-32bit-debuginfo-2.28.4-lp151.2.24.3 - openSUSE Leap 15.1 (noarch): libwebkit2gtk3-lang-2.28.4-lp151.2.24.3


References

https://www.suse.com/security/cve/CVE-2020-9862.html https://www.suse.com/security/cve/CVE-2020-9893.html https://www.suse.com/security/cve/CVE-2020-9894.html https://www.suse.com/security/cve/CVE-2020-9895.html https://www.suse.com/security/cve/CVE-2020-9915.html https://www.suse.com/security/cve/CVE-2020-9925.html https://bugzilla.suse.com/1174662--


Severity
Announcement ID: openSUSE-SU-2020:1256-1
Rating: important
Affected Products: openSUSE Leap 15.1

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo