openSUSE Security Update: Security update for rubygem-actionpack-5_1
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:1575-1
Rating:             important
References:         #1172177 
Cross-References:   CVE-2020-8164
Affected Products:
                    openSUSE Backports SLE-15-SP1
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for rubygem-actionpack-5_1 fixes the following issues:

   - CVE-2020-8164: Possible Strong Parameters Bypass in ActionPack. There is
     a strong parameters bypass vector in ActionPack. (bsc#1172177)

   This update was imported from the SUSE:SLE-15:Update update project. This
   update was imported from the openSUSE:Leap:15.1:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP1:

      zypper in -t patch openSUSE-2020-1575=1



Package List:

   - openSUSE Backports SLE-15-SP1 (aarch64 ppc64le s390x x86_64):

      ruby2.5-rubygem-actionpack-5_1-5.1.4-bp151.2.3.1
      ruby2.5-rubygem-actionpack-doc-5_1-5.1.4-bp151.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-8164.html
   https://bugzilla.suse.com/1172177

-- 

openSUSE: 2020:1575-1: important: rubygem-actionpack-5_1

September 29, 2020
An update that fixes one vulnerability is now available.

Description

This update for rubygem-actionpack-5_1 fixes the following issues: - CVE-2020-8164: Possible Strong Parameters Bypass in ActionPack. There is a strong parameters bypass vector in ActionPack. (bsc#1172177) This update was imported from the SUSE:SLE-15:Update update project. This update was imported from the openSUSE:Leap:15.1:Update update project.

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP1: zypper in -t patch openSUSE-2020-1575=1


Package List

- openSUSE Backports SLE-15-SP1 (aarch64 ppc64le s390x x86_64): ruby2.5-rubygem-actionpack-5_1-5.1.4-bp151.2.3.1 ruby2.5-rubygem-actionpack-doc-5_1-5.1.4-bp151.2.3.1


References

https://www.suse.com/security/cve/CVE-2020-8164.html https://bugzilla.suse.com/1172177--


Severity
Announcement ID: openSUSE-SU-2020:1575-1
Rating: important
Affected Products: openSUSE Backports SLE-15-SP1

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo