openSUSE Security Update: Security update for jackson-databind
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0221-1
Rating:             moderate
References:         #1177616 #1180391 #1181118 
Cross-References:   CVE-2020-25649 CVE-2020-35728 CVE-2021-20190
                   
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for jackson-databind fixes the following issues:

   jackson-databind was updated to 2.10.5.1:
     * #2589: `DOMDeserializer`: setExpandEntityReferences(false) may not
       prevent external entity expansion in all cases (CVE-2020-25649,
       bsc#1177616)
     * #2787 (partial fix): NPE after add mixin for enum
     * #2679: 'ObjectMapper.readValue("123", Void.TYPE)' throws "should never
       occur"

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-221=1



Package List:

   - openSUSE Leap 15.2 (noarch):

      jackson-databind-2.10.5.1-lp152.2.3.1
      jackson-databind-javadoc-2.10.5.1-lp152.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-25649.html
   https://www.suse.com/security/cve/CVE-2020-35728.html
   https://www.suse.com/security/cve/CVE-2021-20190.html
   https://bugzilla.suse.com/1177616
   https://bugzilla.suse.com/1180391
   https://bugzilla.suse.com/1181118