openSUSE Security Update: Security update for nextcloud
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0262-1
Rating:             moderate
References:         #1181445 #1181803 #1181804 
Cross-References:   CVE-2020-8293 CVE-2020-8294 CVE-2020-8295
                   
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for nextcloud fixes the following issues:

   - nextcloud was upgraded to version 20.0.7
      - CVE-2020-8294: Fixed a missing link validation (boo#1181803)
      - CVE-2020-8295: Fixed a denial of service attack (boo#1181804)
      - CVE-2020-8293: Fixed an input validation issue (boo#1181445)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-262=1



Package List:

   - openSUSE Leap 15.2 (noarch):

      nextcloud-20.0.7-lp152.3.6.1
      nextcloud-apache-20.0.7-lp152.3.6.1


References:

   https://www.suse.com/security/cve/CVE-2020-8293.html
   https://www.suse.com/security/cve/CVE-2020-8294.html
   https://www.suse.com/security/cve/CVE-2020-8295.html
   https://bugzilla.suse.com/1181445
   https://bugzilla.suse.com/1181803
   https://bugzilla.suse.com/1181804