openSUSE Security Update: Security update for privoxy
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0279-1
Rating:             moderate
References:         #1181650 
Cross-References:   CVE-2021-20216 CVE-2021-20217
Affected Products:
                    openSUSE Backports SLE-15-SP2
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for privoxy fixes the following issues:

   - Update to version 3.0.31:
     - Security/Reliability (boo#1181650)
       - Prevent an assertion from getting triggered by a crafted CGI
         request. Commit 5bba5b89193fa. OVE-20210130-0001. CVE-2021-20217
         Reported by: Joshua Rogers (Opera)
       - Fixed a memory leak when decompression fails "unexpectedly". Commit
         f431d61740cc0. OVE-20210128-0001. CVE-2021-20216
     - Bug fixes:
       - Fixed detection of insufficient data for decompression. Previously
         Privoxy could try to decompress a partly uninitialized buffer.

   This update was imported from the openSUSE:Leap:15.2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP2:

      zypper in -t patch openSUSE-2021-279=1



Package List:

   - openSUSE Backports SLE-15-SP2 (aarch64 ppc64le s390x x86_64):

      privoxy-3.0.31-bp152.4.6.1

   - openSUSE Backports SLE-15-SP2 (noarch):

      privoxy-doc-3.0.31-bp152.4.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-20216.html
   https://www.suse.com/security/cve/CVE-2021-20217.html
   https://bugzilla.suse.com/1181650