openSUSE Security Update: Security update for postgresql12
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0423-1
Rating:             moderate
References:         #1179765 #1182040 
Cross-References:   CVE-2021-3393
CVSS scores:
                    CVE-2021-3393 (SUSE): 6.2 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for postgresql12 fixes the following issues:

   Upgrade to version 12.6:

   - Reindexing might be needed after applying this update.
   - CVE-2021-3393, bsc#1182040: Fix information leakage in
     constraint-violation error messages.

   This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-423=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libecpg6-12.6-lp152.3.16.1
      libecpg6-debuginfo-12.6-lp152.3.16.1
      libpq5-12.6-lp152.3.16.1
      libpq5-debuginfo-12.6-lp152.3.16.1
      postgresql12-12.6-lp152.3.16.1
      postgresql12-contrib-12.6-lp152.3.16.1
      postgresql12-contrib-debuginfo-12.6-lp152.3.16.1
      postgresql12-debuginfo-12.6-lp152.3.16.1
      postgresql12-debugsource-12.6-lp152.3.16.1
      postgresql12-devel-12.6-lp152.3.16.1
      postgresql12-devel-debuginfo-12.6-lp152.3.16.1
      postgresql12-llvmjit-12.6-lp152.3.16.1
      postgresql12-llvmjit-debuginfo-12.6-lp152.3.16.1
      postgresql12-plperl-12.6-lp152.3.16.1
      postgresql12-plperl-debuginfo-12.6-lp152.3.16.1
      postgresql12-plpython-12.6-lp152.3.16.1
      postgresql12-plpython-debuginfo-12.6-lp152.3.16.1
      postgresql12-pltcl-12.6-lp152.3.16.1
      postgresql12-pltcl-debuginfo-12.6-lp152.3.16.1
      postgresql12-server-12.6-lp152.3.16.1
      postgresql12-server-debuginfo-12.6-lp152.3.16.1
      postgresql12-server-devel-12.6-lp152.3.16.1
      postgresql12-server-devel-debuginfo-12.6-lp152.3.16.1
      postgresql12-test-12.6-lp152.3.16.1

   - openSUSE Leap 15.2 (noarch):

      postgresql12-docs-12.6-lp152.3.16.1

   - openSUSE Leap 15.2 (x86_64):

      libecpg6-32bit-12.6-lp152.3.16.1
      libecpg6-32bit-debuginfo-12.6-lp152.3.16.1
      libpq5-32bit-12.6-lp152.3.16.1
      libpq5-32bit-debuginfo-12.6-lp152.3.16.1


References:

   https://www.suse.com/security/cve/CVE-2021-3393.html
   https://bugzilla.suse.com/1179765
   https://bugzilla.suse.com/1182040