openSUSE Security Update: Security update for ruby2.5
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0471-1
Rating:             important
References:         #1177125 #1177222 
Cross-References:   CVE-2020-25613
CVSS scores:
                    CVE-2020-25613 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
                    CVE-2020-25613 (SUSE): 6.3 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for ruby2.5 fixes the following issues:

   - CVE-2020-25613: Fixed a potential HTTP Request Smuggling  in WEBrick
     (bsc#1177125).
   - Enable optimizations also on ARM64 (bsc#1177222)

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-471=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      libruby2_5-2_5-2.5.8-lp152.2.3.1
      libruby2_5-2_5-debuginfo-2.5.8-lp152.2.3.1
      ruby2.5-2.5.8-lp152.2.3.1
      ruby2.5-debuginfo-2.5.8-lp152.2.3.1
      ruby2.5-debugsource-2.5.8-lp152.2.3.1
      ruby2.5-devel-2.5.8-lp152.2.3.1
      ruby2.5-devel-extra-2.5.8-lp152.2.3.1
      ruby2.5-doc-2.5.8-lp152.2.3.1
      ruby2.5-stdlib-2.5.8-lp152.2.3.1
      ruby2.5-stdlib-debuginfo-2.5.8-lp152.2.3.1

   - openSUSE Leap 15.2 (noarch):

      ruby2.5-doc-ri-2.5.8-lp152.2.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-25613.html
   https://bugzilla.suse.com/1177125
   https://bugzilla.suse.com/1177222