openSUSE Security Update: Security update for hawk2
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0473-1
Rating:             important
References:         #1179999 #1182165 #1182166 
Cross-References:   CVE-2020-35459 CVE-2021-25314
CVSS scores:
                    CVE-2020-35459 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2020-35459 (SUSE): 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-25314 (SUSE): 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that solves two vulnerabilities and has one
   errata is now available.

Description:

   This update for hawk2 fixes the following issues:

   - Update to version 2.6.3:
     * Remove hawk_invoke and use capture3 instead of runas
       (bsc#1179999)(CVE-2020-35459)
     * Remove unnecessary chmod (bsc#1182166)(CVE-2021-25314)
     * Sanitize filename to contains whitelist of alphanumeric (bsc#1182165)

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-473=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      hawk2-2.6.3+git.1614684118.af555ad9-lp152.2.18.1
      hawk2-debuginfo-2.6.3+git.1614684118.af555ad9-lp152.2.18.1
      hawk2-debugsource-2.6.3+git.1614684118.af555ad9-lp152.2.18.1


References:

   https://www.suse.com/security/cve/CVE-2020-35459.html
   https://www.suse.com/security/cve/CVE-2021-25314.html
   https://bugzilla.suse.com/1179999
   https://bugzilla.suse.com/1182165
   https://bugzilla.suse.com/1182166