openSUSE Security Update: Security update for eclipse
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0485-1
Rating:             important
References:         #1183728 
Cross-References:   CVE-2020-27225
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for eclipse fixes the following issues:

   -  CVE-2020-27225: Authenticate active help requests to the local help web
      server (bsc#1183728).

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-485=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      eclipse-bootstrap-debuginfo-4.9.0-lp152.3.3.1
      eclipse-bootstrap-debugsource-4.9.0-lp152.3.3.1
      eclipse-contributor-tools-4.9.0-lp152.3.3.1
      eclipse-contributor-tools-bootstrap-4.9.0-lp152.3.3.1
      eclipse-debuginfo-4.9.0-lp152.3.3.1
      eclipse-debugsource-4.9.0-lp152.3.3.1
      eclipse-equinox-osgi-4.9.0-lp152.3.3.1
      eclipse-equinox-osgi-bootstrap-4.9.0-lp152.3.3.1
      eclipse-pde-4.9.0-lp152.3.3.1
      eclipse-pde-bootstrap-4.9.0-lp152.3.3.1
      eclipse-platform-4.9.0-lp152.3.3.1
      eclipse-platform-bootstrap-4.9.0-lp152.3.3.1
      eclipse-platform-bootstrap-debuginfo-4.9.0-lp152.3.3.1
      eclipse-platform-debuginfo-4.9.0-lp152.3.3.1
      eclipse-swt-4.9.0-lp152.3.3.1
      eclipse-swt-bootstrap-4.9.0-lp152.3.3.1
      eclipse-swt-bootstrap-debuginfo-4.9.0-lp152.3.3.1
      eclipse-swt-debuginfo-4.9.0-lp152.3.3.1
      eclipse-tests-4.9.0-lp152.3.3.1
      eclipse-tests-bootstrap-4.9.0-lp152.3.3.1

   - openSUSE Leap 15.2 (noarch):

      eclipse-jdt-4.9.0-lp152.3.3.1
      eclipse-jdt-bootstrap-4.9.0-lp152.3.3.1
      eclipse-p2-discovery-4.9.0-lp152.3.3.1
      eclipse-p2-discovery-bootstrap-4.9.0-lp152.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-27225.html
   https://bugzilla.suse.com/1183728