openSUSE Security Update: Security update for ovmf
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0495-1
Rating:             moderate
References:         #1183578 #1183579 
Cross-References:   CVE-2021-28210 CVE-2021-28211
CVSS scores:
                    CVE-2021-28210 (SUSE): 5.1 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H
                    CVE-2021-28211 (SUSE): 4.4 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for ovmf fixes the following issues:

   - CVE-2021-28211: ovmf: edk2: possible heap corruption with
     LzmaUefiDecompressGetInfo (bsc#1183578)
   - CVE-2021-28210: ovmf: unlimited FV recursion, round 2 (bsc#1183579)

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-495=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      ovmf-201911-lp152.6.11.1
      ovmf-tools-201911-lp152.6.11.1

   - openSUSE Leap 15.2 (x86_64):

      qemu-ovmf-x86_64-debug-201911-lp152.6.11.1

   - openSUSE Leap 15.2 (noarch):

      qemu-ovmf-ia32-201911-lp152.6.11.1
      qemu-ovmf-x86_64-201911-lp152.6.11.1


References:

   https://www.suse.com/security/cve/CVE-2021-28210.html
   https://www.suse.com/security/cve/CVE-2021-28211.html
   https://bugzilla.suse.com/1183578
   https://bugzilla.suse.com/1183579