openSUSE: 2021:0808-1 moderate: curl

Advisories


   openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0808-1
Rating:             moderate
References:         #1186114 SLE-17956 
Cross-References:   CVE-2021-22898
CVSS scores:
                    CVE-2021-22898 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability, contains one
   feature is now available.

Description:

   This update for curl fixes the following issues:

   - CVE-2021-22898: Fixed curl TELNET stack contents disclosure
     (bsc#1186114).
   - Allow partial chain verification [jsc#SLE-17956]
     * Have intermediate certificates in the trust store be treated as
       trust-anchors, in the same way as self-signed root CA certificates
       are. This allows users to verify servers using the intermediate cert
       only, instead of needing the whole chain.
     * Set FLAG_TRUSTED_FIRST unconditionally.
     * Do not check partial chains with CRL check.

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-808=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      curl-7.66.0-lp152.3.18.1
      curl-debuginfo-7.66.0-lp152.3.18.1
      curl-debugsource-7.66.0-lp152.3.18.1
      curl-mini-7.66.0-lp152.3.18.1
      curl-mini-debuginfo-7.66.0-lp152.3.18.1
      curl-mini-debugsource-7.66.0-lp152.3.18.1
      libcurl-devel-7.66.0-lp152.3.18.1
      libcurl-mini-devel-7.66.0-lp152.3.18.1
      libcurl4-7.66.0-lp152.3.18.1
      libcurl4-debuginfo-7.66.0-lp152.3.18.1
      libcurl4-mini-7.66.0-lp152.3.18.1
      libcurl4-mini-debuginfo-7.66.0-lp152.3.18.1

   - openSUSE Leap 15.2 (x86_64):

      libcurl-devel-32bit-7.66.0-lp152.3.18.1
      libcurl4-32bit-7.66.0-lp152.3.18.1
      libcurl4-32bit-debuginfo-7.66.0-lp152.3.18.1


References:

   https://www.suse.com/security/cve/CVE-2021-22898.html
   https://bugzilla.suse.com/1186114

openSUSE: 2021:0808-1 moderate: curl

May 29, 2021
An update that fixes one vulnerability, contains one feature is now available

Description

This update for curl fixes the following issues: - CVE-2021-22898: Fixed curl TELNET stack contents disclosure (bsc#1186114). - Allow partial chain verification [jsc#SLE-17956] * Have intermediate certificates in the trust store be treated as trust-anchors, in the same way as self-signed root CA certificates are. This allows users to verify servers using the intermediate cert only, instead of needing the whole chain. * Set FLAG_TRUSTED_FIRST unconditionally. * Do not check partial chains with CRL check. This update was imported from the SUSE:SLE-15-SP2:Update update project.

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2021-808=1

Package List

- openSUSE Leap 15.2 (i586 x86_64): curl-7.66.0-lp152.3.18.1 curl-debuginfo-7.66.0-lp152.3.18.1 curl-debugsource-7.66.0-lp152.3.18.1 curl-mini-7.66.0-lp152.3.18.1 curl-mini-debuginfo-7.66.0-lp152.3.18.1 curl-mini-debugsource-7.66.0-lp152.3.18.1 libcurl-devel-7.66.0-lp152.3.18.1 libcurl-mini-devel-7.66.0-lp152.3.18.1 libcurl4-7.66.0-lp152.3.18.1 libcurl4-debuginfo-7.66.0-lp152.3.18.1 libcurl4-mini-7.66.0-lp152.3.18.1 libcurl4-mini-debuginfo-7.66.0-lp152.3.18.1 - openSUSE Leap 15.2 (x86_64): libcurl-devel-32bit-7.66.0-lp152.3.18.1 libcurl4-32bit-7.66.0-lp152.3.18.1 libcurl4-32bit-debuginfo-7.66.0-lp152.3.18.1

References

https://www.suse.com/security/cve/CVE-2021-22898.html https://bugzilla.suse.com/1186114

Severity
Announcement ID: openSUSE-SU-2021:0808-1
Rating: moderate
Affected Products: openSUSE Leap 15.2 ble.

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.