openSUSE Security Update: Security update for virtualbox
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0977-1
Rating:             important
References:         #1182918 #1186361 
Cross-References:   CVE-2021-2145 CVE-2021-2250 CVE-2021-2264
                    CVE-2021-2266 CVE-2021-2279 CVE-2021-2280
                    CVE-2021-2281 CVE-2021-2282 CVE-2021-2283
                    CVE-2021-2284 CVE-2021-2285 CVE-2021-2286
                    CVE-2021-2287 CVE-2021-2291 CVE-2021-2296
                    CVE-2021-2297 CVE-2021-2306 CVE-2021-2309
                    CVE-2021-2310 CVE-2021-2312
CVSS scores:
                    CVE-2021-2145 (NVD) : 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
                    CVE-2021-2250 (NVD) : 8.2 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
                    CVE-2021-2264 (NVD) : 8.4 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
                    CVE-2021-2266 (NVD) : 6 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-2279 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-2280 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-2281 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
                    CVE-2021-2282 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-2283 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-2284 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
                    CVE-2021-2285 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-2286 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
                    CVE-2021-2287 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-2291 (NVD) : 4.7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
                    CVE-2021-2296 (NVD) : 5.3 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-2297 (NVD) : 5.3 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-2306 (NVD) : 6 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-2309 (NVD) : 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
                    CVE-2021-2310 (NVD) : 7.5 CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
                    CVE-2021-2312 (NVD) : 4.4 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes 20 vulnerabilities is now available.

Description:

   This update for virtualbox fixes the following issues:

   - Update vboxdrv.sh per boo#1186361

   Version bump to 6.1.22 (released April 29 2021 by Oracle)

   - This is a maintenance release. The following items were fixed and/or
     added:
   - VMM: Improved performance of 64-bit Windows and Solaris guests when
     Hyper-V is used on recent Windows 10 hosts
   - VMM: Fixed frequent crashes of 64-bit Windows Vista and Server 2003
     guests when Hyper-V is used
   - GUI: Fixed regression where user was not able to save unset default
     shortcuts (bug #20305)
   - Storage: Fixed regression in LsiLogic SAS controller emulation caused VM
     crash (bug #20323)
   - Linux Guest Additions: Fixed issue when it was not possible to run
     executables from mounted share (bug #20320)
   - Fixes for CVE-2021-2145 CVE-2021-2250 CVE-2021-2264 CVE-2021-2266
     CVE-2021-2279 CVE-2021-2280 CVE-2021-2281 CVE-2021-2282 CVE-2021-2283
     CVE-2021-2284 CVE-2021-2285 CVE-2021-2286 CVE-2021-2287 CVE-2021-2291
     CVE-2021-2296 CVE-2021-2297 CVE-2021-2306 CVE-2021-2309 CVE-2021-2310
     CVE-2021-2312

   - Improve autostart security boo#1182918.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-2021-977=1



Package List:

   - openSUSE Leap 15.3 (x86_64):

      python3-virtualbox-6.1.22-lp153.2.3.2
      python3-virtualbox-debuginfo-6.1.22-lp153.2.3.2
      virtualbox-6.1.22-lp153.2.3.2
      virtualbox-debuginfo-6.1.22-lp153.2.3.2
      virtualbox-debugsource-6.1.22-lp153.2.3.2
      virtualbox-devel-6.1.22-lp153.2.3.2
      virtualbox-guest-tools-6.1.22-lp153.2.3.2
      virtualbox-guest-tools-debuginfo-6.1.22-lp153.2.3.2
      virtualbox-guest-x11-6.1.22-lp153.2.3.2
      virtualbox-guest-x11-debuginfo-6.1.22-lp153.2.3.2
      virtualbox-kmp-debugsource-6.1.22-lp153.2.3.2
      virtualbox-kmp-default-6.1.22_k5.3.18_59.5-lp153.2.3.2
      virtualbox-kmp-default-debuginfo-6.1.22_k5.3.18_59.5-lp153.2.3.2
      virtualbox-kmp-preempt-6.1.22_k5.3.18_59.5-lp153.2.3.2
      virtualbox-kmp-preempt-debuginfo-6.1.22_k5.3.18_59.5-lp153.2.3.2
      virtualbox-qt-6.1.22-lp153.2.3.2
      virtualbox-qt-debuginfo-6.1.22-lp153.2.3.2
      virtualbox-vnc-6.1.22-lp153.2.3.2
      virtualbox-websrv-6.1.22-lp153.2.3.2
      virtualbox-websrv-debuginfo-6.1.22-lp153.2.3.2

   - openSUSE Leap 15.3 (noarch):

      virtualbox-guest-desktop-icons-6.1.22-lp153.2.3.2
      virtualbox-guest-source-6.1.22-lp153.2.3.2
      virtualbox-host-source-6.1.22-lp153.2.3.2


References:

   https://www.suse.com/security/cve/CVE-2021-2145.html
   https://www.suse.com/security/cve/CVE-2021-2250.html
   https://www.suse.com/security/cve/CVE-2021-2264.html
   https://www.suse.com/security/cve/CVE-2021-2266.html
   https://www.suse.com/security/cve/CVE-2021-2279.html
   https://www.suse.com/security/cve/CVE-2021-2280.html
   https://www.suse.com/security/cve/CVE-2021-2281.html
   https://www.suse.com/security/cve/CVE-2021-2282.html
   https://www.suse.com/security/cve/CVE-2021-2283.html
   https://www.suse.com/security/cve/CVE-2021-2284.html
   https://www.suse.com/security/cve/CVE-2021-2285.html
   https://www.suse.com/security/cve/CVE-2021-2286.html
   https://www.suse.com/security/cve/CVE-2021-2287.html
   https://www.suse.com/security/cve/CVE-2021-2291.html
   https://www.suse.com/security/cve/CVE-2021-2296.html
   https://www.suse.com/security/cve/CVE-2021-2297.html
   https://www.suse.com/security/cve/CVE-2021-2306.html
   https://www.suse.com/security/cve/CVE-2021-2309.html
   https://www.suse.com/security/cve/CVE-2021-2310.html
   https://www.suse.com/security/cve/CVE-2021-2312.html
   https://bugzilla.suse.com/1182918
   https://bugzilla.suse.com/1186361