openSUSE Security Update: Security update for chromium
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1396-1
Rating:             important
References:         #1191844 
Cross-References:   CVE-2021-37981 CVE-2021-37982 CVE-2021-37983
                    CVE-2021-37984 CVE-2021-37985 CVE-2021-37986
                    CVE-2021-37987 CVE-2021-37988 CVE-2021-37989
                    CVE-2021-37990 CVE-2021-37991 CVE-2021-37992
                    CVE-2021-37993 CVE-2021-37994 CVE-2021-37995
                    CVE-2021-37996
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes 16 vulnerabilities is now available.

Description:

   This update for chromium fixes the following issues:

   Chromium 95.0.4638.54 (boo#1191844):

   * CVE-2021-37981: Heap buffer overflow in Skia
   * CVE-2021-37982: Use after free in Incognito
   * CVE-2021-37983: Use after free in Dev Tools
   * CVE-2021-37984: Heap buffer overflow in PDFium
   * CVE-2021-37985: Use after free in V8
   * CVE-2021-37986: Heap buffer overflow in Settings
   * CVE-2021-37987: Use after free in Network APIs
   * CVE-2021-37988: Use after free in Profiles
   * CVE-2021-37989: Inappropriate implementation in Blink
   * CVE-2021-37990: Inappropriate implementation in WebView
   * CVE-2021-37991: Race in V8
   * CVE-2021-37992: Out of bounds read in WebAudio
   * CVE-2021-37993: Use after free in PDF Accessibility
   * CVE-2021-37996: Insufficient validation of untrusted input in Downloads
   * CVE-2021-37994: Inappropriate implementation in iFrame Sandbox
   * CVE-2021-37995: Inappropriate implementation in WebApp Installer


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1396=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      chromedriver-95.0.4638.54-lp152.2.135.1
      chromedriver-debuginfo-95.0.4638.54-lp152.2.135.1
      chromium-95.0.4638.54-lp152.2.135.1
      chromium-debuginfo-95.0.4638.54-lp152.2.135.1


References:

   https://www.suse.com/security/cve/CVE-2021-37981.html
   https://www.suse.com/security/cve/CVE-2021-37982.html
   https://www.suse.com/security/cve/CVE-2021-37983.html
   https://www.suse.com/security/cve/CVE-2021-37984.html
   https://www.suse.com/security/cve/CVE-2021-37985.html
   https://www.suse.com/security/cve/CVE-2021-37986.html
   https://www.suse.com/security/cve/CVE-2021-37987.html
   https://www.suse.com/security/cve/CVE-2021-37988.html
   https://www.suse.com/security/cve/CVE-2021-37989.html
   https://www.suse.com/security/cve/CVE-2021-37990.html
   https://www.suse.com/security/cve/CVE-2021-37991.html
   https://www.suse.com/security/cve/CVE-2021-37992.html
   https://www.suse.com/security/cve/CVE-2021-37993.html
   https://www.suse.com/security/cve/CVE-2021-37994.html
   https://www.suse.com/security/cve/CVE-2021-37995.html
   https://www.suse.com/security/cve/CVE-2021-37996.html
   https://bugzilla.suse.com/1191844