openSUSE Security Update: Security update for squid
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1419-1
Rating:             moderate
References:         #1189403 
Cross-References:   CVE-2021-28116
CVSS scores:
                    CVE-2021-28116 (NVD) : 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
                    CVE-2021-28116 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for squid fixes the following issues:

   Update to version 4.17:

   - CVE-2021-28116: Fixed a out-of-bounds read in the WCCP protocol
     (bsc#1189403).

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1419=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      squid-4.17-lp152.2.12.1
      squid-debuginfo-4.17-lp152.2.12.1
      squid-debugsource-4.17-lp152.2.12.1


References:

   https://www.suse.com/security/cve/CVE-2021-28116.html
   https://bugzilla.suse.com/1189403